HomeGroupsTalkZeitgeist
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

Add other authors tool not working.

Bug Collectors

Join LibraryThing to post.

1Sylak
Edited: May 20, 2015, 3:34pm Top

The 'add other authors' tool under 'other authors' on the main works page is no longer working.

The feature appears to work correctly, up to a point; but 'save author' button once pressed does not add or change the author.

ipad iOS 8.3

------Update------

Just tested on a PC using Windows 8.1 and it works perfectly.
Confirmation that this is an apple OS incompatibility.

Probably still worth looking into for all us apple ipad users. ;)

2Sylak
Aug 24, 2015, 6:14pm Top

Tested this issue again today under Apple's latest OS 8.4.1
Still does not work. :/

3lilithcat
Aug 24, 2015, 6:51pm Top

Looks like it's just on iPad. It works fine on my iMac.

4Sylak
Aug 25, 2015, 4:49am Top

3>
That's helpful. Thank you.

I also tested it on my wife's HUDL 2 using Android v. 4.4.2 - it worked fine on that.

What a pain.
I have been an exclusive ipad user for the past three years.
On the whole I use it without a glitch. However, I have reported at least two or three irritating problems related to functionality On LT.

I don't expect immediate assistance from the team. But, I do hope that they will keep it on the backburner, and one day come up with a fix for these issues.

5MarthaJeanne
Aug 25, 2015, 5:33am Top

I find I can always add an author. But changing the main author is chancy. It works better in landscape, and the type of touch used is very picky.

6timspalding
Sep 25, 2015, 10:31pm Top

Assigning to ConceptDawg, who has iPhone testing tools I don't have.

7Sylak
Nov 12, 2015, 3:13pm Top

This is still a bug under iOS 9.1

8conceptDawg
Nov 16, 2016, 2:18pm Top

Just tested on various iOS iPad simulators (iOS10, iOS9 on Air, Standard iPad, etc.).
All worked fine for adding an author and changing the old one.

Still trying to find a breaking point on this one.

9MarthaJeanne
Edited: Nov 16, 2016, 2:40pm Top

I've had better luck with this recently. Still hit or miss, but it works enough of the time that I find it worth trying.

I think I'm still running iOS 8.4, though. This machine doesn't have enough storage to even attempt to upgrade.

10timspalding
Aug 21, 10:31am Top

Has anyone seen this recently? Can you give me a specific page and URL that it's not working for?

11spiphany
Oct 6, 3:29am Top

I tried to change the main author for Chronicle of a Fall from Grace from Sándor Márai to Sándor Lsg Márai (a confusingly chosen pen name, not the same person at all) and I'm having the same problem mentioned in >5 MarthaJeanne:: it acts like it works but then doesn't actually change. I'm using Firefox 56.0 on a Windows 7 machine.

12timspalding
Oct 6, 10:54am Top

I'm going to try. What's the last name—Márai?

13timspalding
Oct 6, 10:56am Top

Okay, I changed it. No problem. http://www.librarything.com/work/14380325

So… hmm. Where did you think you were changing it? We are talking about the work here, not a book, right?

14spiphany
Edited: Oct 6, 3:03pm Top

Yes, I was trying to edit the main author of the work (in the "add other authors" box). It would let me edit it and type in a new name, but the change wouldn't take. I add secondary authors (translators) frequently, and I have never had issues there. Oh, yes, and I use the librarything.de website, if that should happen to make a difference?

Clicking on the author still redirects me to http://www.librarything.com/author/maraisandor. Is that what is supposed to happen? I was trying to get it to move to the same page as the author's other works: http://www.librarything.com/author/maraisandorlsg.

I also just discovered that it is possible to confirm (but not delete or edit) suggested authors in the "add other authors box" of a work when not logged into LibraryThing. This was not the cause of the problem before, but I'm mentioning it in case there's a connection.

15MarthaJeanne
Edited: Oct 6, 3:39pm Top

I clicked on recalculate, and now it seems to be working correctly.

The author looked right on the work, but went to the wrong author page.
The link in other authors was working correctly.

Correction, I still had to combine authors.

Group: Bug Collectors

846 members

87,977 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 191298

Category: Browser and device quirks

Assigned to conceptDawg

Reported by Sylak

Status: Needs discussion

Aug 21, 10:31am

61 days since last change

By timspalding

Status log

Reported. Sylak (May 20, 2015, 8:28am)

Needs discussion. timspalding (Aug 21, 10:31am)

About

This topic is not marked as primarily about any work, author or other topic.

You are using the new servers! | About | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 118,647,134 books! | Top bar: Always visible