HomeGroupsTalkZeitgeist
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

Local Venue not appearing in Local Search

Bug Collectors

Join LibraryThing to post.

1Birlinn
Oct 26, 2018, 12:58am Top

https://www.librarything.com/venue/29451/Sackville-Public-Library

The location for this venue is correctly formatted, and appears properly in the google maps sidebar on the venue page.

Unfortunately, it does not appear when searching for venues in the local area:

https://www.librarything.com/local/place/sackville+new+brunswick

Possibly an issue with the postal code not linking correctly?

If you click on the venue address it takes you to Portland, with a number of other similarly "lost venues" from New York, UK, France, Switzerland, etc, with a supposed distance of 0.0 miles.

https://www.librarything.com/local/place/Sackville%2C+New+Brunswick%2C+E4L+4A7%2...

If you search for only the postal code, it likewise takes you to Portland:

https://www.librarything.com/local/place/E4L+4A7

If I remove the postal code the google maps sidebar still gives the proper address, clicking on the address will take you to the Sackville New Brunswick Local, but the library will not appear in the local search result (though other locations in the town are working properly).

When editing the address, on the edit page it will briefly pop up a google maps books which quickly moves from "checking" to "address not found" . . . though when saved it evidently has no difficulty in finding the address and displaying it on the local venue page.

Sometimes these address searches can be picky, so I tried using variants such as NB for New Brunswick, St for Street, space or no space between the two halves of the postal code etc, but to no avail. Other locations in the province (and the same town) both use Street/St and NB/New Brunswick interchangeably with no issue.

2lorannen
Oct 26, 2018, 11:36am Top

>! "If I remove the postal code..." are you talking about removing it in a search or from the venue page for the Sackville PL?

"a google maps books which quickly moves" Sorry, I don't follow this part. Give me step-by-step details on what you're doing here?

3Birlinn
Oct 26, 2018, 2:09pm Top

Regarding Postal Code:

On the 'Sackville Public Library' venue page under "edit venue info" - I tried removing the postal code and re-adding it to see if that made any difference, but the results were the same.

Regarding the second portion:

When you edit a venue, before you submit your changes there is a widget that is immediately to the right of the "City," State/Territory," "Country," "Phone number," etc boxes.

Each time you edit and make changes to one of the address specific boxes, this widget will attempt to verify the address

(e.g. if you were to change the address from 66 to 65 main street, the widget will display "checking . . . " for a second or two before quickly changing to "Address not found")

If I were to hazard a guess, whatever criteria this widget uses to find the address has failed, and therefore defaults to Portland (as do those other venues that default to within 0.0 miles of that location). So while the google maps location on the venue page is correct, the Sackville Public Library will not appear on any local venue lists as the system believes erroneously that it exists in the default Portland location.

4rodneyvc
Oct 29, 2018, 6:48am Top

>3 Birlinn: I've been doing some venue maintenance, and I'm seeing similar behaviour when doing a search by location at http://www.librarything.com/local

I know that in the past I have not required the postcode in the location text to get reliable results.

For instance, if I search for "Trentham, Victoria, Australia" I get a weird set of results with "Upper Saint Clair Township Library (0.0 miles)
1820 McLaughlin Run Road, Upper Saint Clair, PA 15241" at the top, and the map is centred on Portland, Maine.

If I search for "Trentham, Victoria, 3458, Australia" I get the expected results.

I thought that maybe it's because the location is ambiguous. But I can search for other places by town/city name only and get sensible results. It seems to be either a caching issue, or exceeding a google map API call issue.

5rodneyvc
Oct 29, 2018, 6:58am Top

>4 rodneyvc: I've just added a library for Trentham, Victoria, and the map in the edit page fails to load properly (briefly a "Are you the owner of this site" shows up before the map goes blank)

The map shown after the edits are saved is for Daylesford, which is the venue I cloned to create the Trentham Library, which is why I suspect caching may be an issue.

I'll leave it for a while and see what happens after things propagate properly.

6davidgn
Edited: Nov 22, 2018, 11:59am Top

Try searching "83 bell street, london, uk" or "NW1 6T8" where I've just added Archive Bookstore. (Venue #112215)

Get deposited in Portland, OR around Franklin and Cumberland. Local venues show:

Local venues
toggle favoriteCletwr (0.0 miles)
Tre'r-ddôl, Llangynfelyn, Ceredigion SY20 8PN
toggle favoriteLlibreria Fènix (0.0 miles)
Carrer de la Mercè, Badalona, Spain
toggle favorite三省堂書店 品川駅南店 Books Sanseido - Shinagawa Station Minami (South Exit.) store (0.0 miles)
港南2-1-78, 港区, 東京都 108-0075 Japan
toggle favoriteColes - Tillicum Mall (0.0 miles)
19 - 3170 Tillicum Road, Victoria, BC V9A 7C5 Canada
toggle favoriteSackville Public Library (0.0 miles)
66 Main Street, Sackville, New Brunswick E4L 4A7 Canada
toggle favoriteCanolfan y Celfyddydau Aberystwyth Arts Centre (0.0 miles)
Penglais, Aberystwyth, Ceredigion SY23 3DE United Kingdom
toggle favoriteAntiquariat von Matt (0.0 miles)
Hans von Matt Weg 3, Stans, 6370 Switzerland
toggle favoriteAmazon Books (Austin) (0.0 miles)
11700 Rock Rose Ave Ste 150, Austin, TX 78758
toggle favoriteCostco (0.0 miles)
28 Stavanger Drive, St. John's, Newfoundland and Labrador Canada
toggle favoriteBooks-A-Million #944 (0.0 miles)
2620 Watson Blvd, Warner Robins, GA 31093
toggle favoriteUbu Books (0.0 miles)
Unit 1. open market, Brighton, Bn1 4ju United Kingdom
toggle favoriteLilydale Library (0.0 miles)
1 Jarlo Drive Lilydale, Melbourne, Victoria 3140 Australia
toggle favorite書肆吉成 丸ヨ池内GATE6F店 ‏ (0.0 miles)
中央区南1条西2丁目, 札幌市, 北海道 060-0061 Japan
toggle favoriteAlibri Llibreria (0.0 miles)
Carrer de Balmes, 26, Barcelona, 08007 Spain
toggle favoriteLibrary and Information Center, Kyoto Seika University - 京都精華大学情報館 (0.0 miles)
左京区岩倉木野町137, 京都市, 京都府 606-8588 Japan
toggle favoriteUpper Saint Clair Township Library (0.0 miles)
1820 McLaughlin Run Road, Upper Saint Clair, PA 15241
toggle favoriteFabrica De Historietas (0.0 miles)
Ayacucho 19, Ciudad Autonoma de Buenos Aires, Capital Federal Argentina
toggle favoriteAntiquariat René Krieger (0.0 miles)
Kurze-Geismar-Straße 17, Göttingen, Niedersachsen 37073 Germany
toggle favoriteHilton Garden Inn Las Vegas Strip South (0.0 miles)
7830 South Las Vegas Boulevard,, Las Vegas,, Nevada 89123
toggle favoritePeter and Rachel Reynolds (0.0 miles)
1 Brookside Villas, South Church, BISHOP AUCKLAND, County Durham DL14 6SW United Kingdom
toggle favoriteD&R (Ankamall) (0.0 miles)
Ankamall AVM, Kat:2 No:209-210-211 Akköprü, İskitler, Ankara, Altındağ Turkey
toggle favoriteD&R (Sabiha Gökçen Havalimanı) (0.0 miles)
Sabiha Gökçen Havalimanı, Yeni Terminal, Giden Yolcu Katı. Kara Tarafı DL-726 Kurtköy, İstanbul, Pendik Turkey
toggle favoriteCambridge University Press Bookstore (0.0 miles)
toggle favoriteNorth United Methodist Church Fall Craft Fair and Bazaar (0.0 miles)
3808 N MERIDIAN ST, Indianapolis, IN 46208
toggle favoriteSt. Catherine's Hospice Book Shop, Ashton (0.0 miles)
73 Wellington Road, Ashton, Preston, Lancashire PR2 1BX United Kingdom
» 5 more venues

This is NOT correcting itself.

7davidgn
Nov 22, 2018, 12:04pm Top

And now I find that my 112215 is a duplicate of 51753, but I had to discover that by searching on "London" in Local and scrolling the map manually.

Leaving for now for debugging purposes.

8rodneyvc
Nov 22, 2018, 2:29pm Top

Almost four weeks later and https://www.librarything.com/venue/112120/Hepburn-Libraries-Trentham-Library is still showing the wrong map.

9davidgn
Nov 22, 2018, 8:09pm Top

>8 rodneyvc: Feel your pain, but I have to say the topological black hole of all these collocated venues (at least one of which also appears as a pin at its correct place on the global map) is the more intriguing manifestation.

Most of these "black hole" locations seem to be recently-added ones--although a few seem to have serials in the 30k range, which adds to the perplexity).

10davidgn
Nov 24, 2018, 6:51pm Top

Another report:

https://www.librarything.com/topic/299189
https://www.librarything.com/topic/299190

MaricaB states:
"Hey folks-- New here so maybe I'm missing something but I entered my town & state as my private address, and my state-- Mississippi-- as my public address. The "local" results are from all over the US and beyond. I expected returns of nearby folks, groups, stores, etc. What have I missed?"

Clearly, users are going to have hit-or-miss experiences of this sort with Local until the issue here is properly addressed.

11anglemark
Nov 30, 2018, 4:01am Top

So when I change my residence address by adding my street address to just the city, I get dumped into Portland, Maine. Is someone even looking at this bug?

12lorannen
Nov 30, 2018, 10:32am Top

>11 anglemark: Yes, it's on my to-do list, but I'm rather swamped with SantaThing today. We've also had some development folks out of the office. Hoping to get to this next week. Thanks for your patience!

Can you clarify for me that you're referring here to changing your address on your profile?

13anglemark
Nov 30, 2018, 11:17am Top

>12 lorannen: Can you clarify for me that you're referring here to changing your address on your profile?

On the https://www.librarything.com/local page I changed Local Settings>Location from just "Uppsala" to "Strandbodgatan 1, Uppsala, Sweden" (to be on the safe side).

14WeeTurtle
Jan 27, 10:52pm Top

Attempted some more work in Librarything Local today and encountered a few issues. I think some of these have been mentioned but here's what I encountered today:

- "Local" home page shows the right map but when I search it still shows somewhere in Oregon (I think).

- Clicking any previous search option from the drop down menu when searching venue by name will come back with a "no results." I found I had to type the search term in the box each time for it to work.

- I could make the address search work but only with very basic addresses (punctuation and formatting I assume). I would search only by city and province (in my case, I'm in Canada) and then pan around the map from there, clicking and searching the venue list to find what I was looking for.

An aside: I was trying to organize the Indigo venue in the Vancouver area but may have hit the wrong button and added when I should have edited, etc. I believed I have my mess cleaned up now. The issues with the search made it a bit of a headache to track down venues for error checks. Is there a place where I can see the venues I've specifically edited or changed?

15Conkie
Jan 31, 4:30pm Top

>14 WeeTurtle: Ditto the comment (that) they have encountered issues on LT Local that have been mentioned in this string previously.
>10 davidgn: Ditto the comment (that) users will continue to have hit-or-miss experiences with LT Local until the problem is addressed

>12 lorannen: What is the status of the mapping issue of LT Local venues (such as Little Free Libraries, etc)?

I am currently adding/cleaning up LFL on LT Local for Lincoln NE, and of the 17 LFLs listed for Lincoln, NE...

https://www.librarything.com/local_directory.php?subtype=1

only 3 show as Lincoln, NE Local on this search page:

https://www.librarything.com/local/littleplace/Lincoln%2C+NE

NOTE #1: You'll need to click on "Nebraska" in the first link, because for I could not successfully transfer the link to the next webpage, here for explanatory purposes.

NOTE #2: When I first started adding/cleaning up the Lincoln LDLs, the number shown in the 2nd link above was 7 or 8. They kept disappearing, for unknown reasons.

16ndrose
Apr 4, 7:37am Top

I don't know whether this is the same bug, but I'm reporting it here because it seems likely to be related in cause.

Venues I have added lately do not appear correctly on Local. Some look right on the map, some do not. None appear on the map of "places visited" though they are all marked visited.

On my list of venues added, they appear at the end of the list, all as being 5,528.6 miles away! Is that a clue? Maybe that's where Limbo is.

17ndrose
Apr 4, 7:42am Top

Also perhaps related: on a recent trip, I noticed that entering many place names in the Local search returned far away results. I could get the area I wanted by trying other, nearby place names. For instance, it gave me the right area for "Glasgow, KY", but "Bowling Green, KY" put me across the country. That was a couple of days ago. Currently, "Bowling Green, KY" is working; though it does not show the venue I added there.

18lorax
Apr 4, 8:26am Top

ndrose (#16):


On my list of venues added, they appear at the end of the list, all as being 5,528.6 miles away!


Assuming the venues you've added are local to your profile location, that's an indication that they're being geolocated to a latitude and longitude of (0,0). (Or, I suppose, that they're right and your location is coming through as (0,0).)

19ndrose
Apr 4, 9:07am Top

One correction: the list on which distances appear is not venues added, but "your visited".

20johnandlisa
Apr 9, 10:03am Top

Anything further on ndrose's observation? We're having the same issue with "your visited" (often when combined with a venue we have added.) https://www.librarything.com/local/visited/johnandlisa (you may need to scroll to end to find them. We added several antiquarian bookstores when we visited in France. We can find them if we search by name, but not if we search by location. But there is also one location, Port Richmond Books, https://www.librarything.com/venue/73924/Port-Richmond-Books which has the same problem, even though it was added by someone else and we have only visited it. When I zoom all the way out on the map on the your visited page, I see a dot at 0,0, but only for one bookstore (presumably all the others are hiding underneath the top one). Most recently, we added two versions of Inkwood Books in Haddonfield NJ because we didn't see the first one we entered when we searched on Haddonfield. https://www.librarything.com/local_search.php?vsm=name&q=Inkwood+Books&v... (I mention this because I didn't mark that one as "visited" which we have been trying to limit to used book stores, not all book stores and libraries.) At this point there are probably a lot of bookstores we have either added ourselves or marked as visited which we can't find unless we remember the name of the bookstore and think to search on that rather than by location. Any way to recover these and make sure they turn up in our feed without our having to figure out which ones they are?

21johnandlisa
Apr 9, 10:33am Top

By the way... When I searched on location 0,0 I got an interesting, but hard to interpret list: https://www.librarything.com/local/place/0%2C0 The Inkwood Books I mentioned is there, as is one of the eight or so French bookstores I entered https://www.librarything.com/venue/112995/Théo-Phil. Also the Sackville Public Library that Birlinn mentioned and a few little libraries in Lincoln, NE that must be what Conkie is working on. But Port Richmond Books is not listed, nor the other French bookstores. So I might be wrong about where the other dots for places we have visited might be located. Also no sign of Hepburn Libraries Trentham Library that rodneyvc mentions.

22Sylak
May 1, 1:12pm Top

Searches for bookshops etc. in the UK are still defaulting to Portland.
I didn't think that 6 months on this issue would still remain un-fixed. Is fixing the search on librarything Local not considered a big enough issue to resolve, or is it part of a more complex matter?

23anglemark
Edited: May 1, 2:38pm Top

>22 Sylak: Yeah, I'm curious too. I would have thought that this bug merited faster action.

24davidgn
May 1, 9:30pm Top

Agreed. Some communication would be nice.

25lorannen
May 3, 2:00pm Top

This bug has a lot of moving parts and I'm re-testing. Hope to have some idea of the source of the problem shortly.

Group: Bug Collectors

903 members

92,483 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 297971

Category: LibraryThing Local

Assigned to all

Reported by Birlinn

Status: Reported

Oct 26, 2018, 12:58am

208 days since last change

By Birlinn

Status log

Reported. Birlinn (Oct 26, 2018, 12:58am)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 134,798,971 books! | Top bar: Always visible