HomeGroupsTalkZeitgeist
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

"Invalid response from server"

Bug Collectors

Join LibraryThing to post.

1Louquas
Edited: Jan 29, 4:29pm Top

"Invalid response from server" is what pops up whenever I try to scan a bar-code add a book to my library with the LibraryThing Android app.

2conceptDawg
Jan 29, 4:38pm Top

Hm. It's working for me here (on a VERY old Android phone). Can you tell me if it's failing on every scan and on different books? Can you send me a picture or an ISBN number? I'll test against that particular book. Also, have you changed your source for adding books in the app preferences? By default it's Amazon and Overcat.

3MarthaJeanne
Jan 29, 4:55pm Top

Why do people mark their own bugs down from an open bug report to 'needs discussion'? https://wiki.librarything.com/index.php/Bug_tracking

4Louquas
Jan 29, 10:33pm Top

Maybe because they have never had a bug before, never knew this page existed before today, and do not really know what that drop-down menu means or is for. Sorry if that bugged you. ;)

5lorax
Jan 30, 8:41am Top

It's not that it bugs us, it's just that (1) "Needs discussion" is a status that's less likely to get addressed than "Reported" and (2) not all people have the "I don't know what this does, so I'll change stuff at random" approach to figuring things out.

6AngelaB86
Edited: Jan 31, 2:45pm Top

Deleted for reasons

7conceptDawg
Feb 26, 2:12pm Top

So this one should be fixed. If you're still having problems with the latest version of the Android app (v1.1.1) then let us know. I'm going mark this as fixed but it can always be reopened if you find that you're still having problems.

8Ellen-Key-Schule
Edited: Apr 10, 9:13am Top

Okay, so here we go again: My Android App v. 1.1.1 b26 on my Android 9 Phone as well as an Android 7.0 Tablet has trouble with almost ANY German catalogue i try to use (except for Amazon!), namely "Gemeinsamer Bibliotheksverbund (GBV)", "German National Library" (DNB?), KoBV / Bibliotheken Berlins. The funny thing is that, three days ago, it worked at lest a few times with GBV, and all of these catalogs work with the regular web interface, at least most of the time.
The Error displayed usually is "No entries found" even if that particular ISBN is in the catalog, but sometimes it says "could not connect".
I have tried unchecking all of the catalogs and checking only a single one, switching the "quick search" on and off, but nothing seems to work unless I check amazon.de. Unfortunately, Amazon catalogs some things differently then most of Germanys public libraries ...

9Ellen-Key-Schule
Edited: Apr 10, 9:14am Top

This message has been deleted by its author.

Group: Bug Collectors

903 members

92,493 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 303158

Category: Uncategorized

Assigned to all

Reported by Louquas

Status: Reopened

Apr 10, 9:12am

46 days since last change

By Ellen-Key-Schule

Status log

Reported. Louquas (Jan 29, 3:46pm)

Needs discussion. Louquas (Jan 29, 4:29pm)

Needs discussion. Louquas (Jan 29, 10:33pm)

Fixed. conceptDawg (Feb 26, 2:12pm)

Reopened. Ellen-Key-Schule (Apr 10, 9:08am)

Reopened. Ellen-Key-Schule (Apr 10, 9:12am)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 134,907,242 books! | Top bar: Always visible