HomeGroupsTalkZeitgeist
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

http not being honored in LT talk

Bug Collectors

Join LibraryThing to post.

1lesmel
Feb 2, 5:09pm Top

Not every domain is using https. If I post a link that is http, LT talk should be honoring that I'm know what the heck I'm typing and I mean HTTP not HTTPS. -a href- tags 1/2 work, badly.

Example:
No html coding...
http://annabellewhite.com/buttermilk-scones/buttermilk-scones/ looks like http, right? Mouse over the link. It is directing you to https and that site doesn't use https.

HTML coding...
http://annabellewhite.com/buttermilk-scones/buttermilk-scones looks like http, coded as http...isn't http.

HTML coding...
But this is http

LT Talk, you are drunk and disorderly and annoying me.

Proof that I'm using http not https...

2rodneyvc
Feb 2, 8:07pm Top

>1 lesmel: I'm not sure it's totally LT with the problem. It seems to depend on how you are getting to LT in the first place.

For instance, I'm using FF 65 on a mac. Somehow I can be on the talk page via 'http://www.librarything.com/talk' or 'https://www.librarything.com/talk' or 'www.librarything.com/talk' i.e. that's what's showing up in the navigation bar. FF rewrites the links I click on to match the protocol in the navigation URL!

3lesmel
Feb 2, 9:14pm Top

Well, there is an old bug about https links not working, so...the reverse is happening.

4connie53
Feb 3, 1:37am Top

I have http problems to. I use http to make stars but they don't work anymore. I need to use https, but you can't just put an 's' in. Then the link is broken too. So my stars don't show. Just like >3 lesmel: mentioned.

5divinenanny
Feb 3, 2:01pm Top

LT sucks at HTTP/HTTPS and this looks like the same thing that is happening in the latter half of the posts in this thread: https://www.librarything.com/topic/302508.

Group: Bug Collectors

902 members

92,476 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 303355

Category: Talk pages

Assigned to all

Reported by lesmel

Status: Reported

Feb 2, 5:09pm

107 days since last change

By lesmel

Status log

Reported. lesmel (Feb 2, 5:09pm)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 134,772,610 books! | Top bar: Always visible