HomeGroupsTalkZeitgeist
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

Request Throttled?

Bug Collectors

Join LibraryThing to post.

1Littlemissbashful
Edited: Feb 13, 5:06am Top

I'm struggling to add any item to my library, no matter how I try and enter it (or which database I use for look-up) no results are coming up and I'm seeing a 'ResultThrottled' error message (which I'm not familiar with?)

I have tried looking up with ASIN, ISBN, Title and Author using Amazon.uk and Amazon.com All Media with no joy:

ASIN: B07KFM66BJ
ISBN: 1786817446
Title: Where She Lies
Author: Michael Scanlon

I tried a random alternative just to see if it was this particular book causing the problem but apparently not.

Also tried by title: The Edge of the Crazies

Is it a bug or something weird my end...

2gilroy
Feb 13, 5:13am Top

What happens when you send a request to a source OTHER than Amazon?

3Littlemissbashful
Feb 13, 5:16am Top

Checking....

4Littlemissbashful
Feb 13, 5:17am Top

Same thing with Overcat

5Littlemissbashful
Feb 13, 5:19am Top

Result just popped up now!

6MarthaJeanne
Feb 13, 5:22am Top

Try Amazon.com books. It does not seem to be in library sources yet.

I think the request throttled has to do with Amazon limiting the number of LT queries they allow.

7Littlemissbashful
Edited: Feb 13, 5:26am Top

#6 Okay, good to know... Issue seems to have resolved as suddenly popped up on Amazon.uk. Closing bug, if it happens again I guess I'll just wait it out... Many thanks

8BerndP
Edited: Feb 13, 12:52pm Top

I have exactly the same problem. I mostly try to add German books through Amazon.de - no results since yesterday. Same with Overcat. I always get the "result throttled" error message. (Same with Amazon.co.uk. Only Amazon.com seems to work more or less.)

9lorax
Feb 13, 1:52pm Top

Getting this from various Amazons makes sense. Getting this with Overcat, less so.

10BerndP
Feb 13, 5:02pm Top

I have to correct myself. Overcat is indeed working. (I must have clicked the wrong source while searching.) It just doesn't find the books I'm looking for. :-) Amazon however still tells me "RequestThrottled" (and that is something I have never experienced before).

11jab2004
Feb 13, 6:42pm Top

Amazon.com overcat and british Library appears to be working for me but amazon.co.uk i am getting the Request Throttled.

12CecileB
Feb 14, 2:03am Top

Hi!
I have the same error message for Amazon.fr and I can't add books.

13MarthaJeanne
Feb 14, 3:15am Top

This is not really an LT bug. It is an explanation of why there isn't a search result. Try another source or enter the book manually.

14divinenanny
Feb 14, 3:27am Top

>13 MarthaJeanne:
Why not? It seems to me that it is up to LT to check this out and "fix"/contact/check Amazon on why the requests are being throttled?

15gilroy
Feb 14, 5:19am Top

This is actually a known issue with Amazon (all of them) because LT and its members haven't used links to buy books from Amazon. It comes up about every 6 months, I want to say. But it is an Amazon issue, but it has to be listed as a bug so the admin can spend the next week filling in the forms (again) to fix the connections.

It's one reason why other library sources are encouraged. And why we have more than 700 other sources besides Amazon.

16Caroline_McElwee
Feb 14, 8:22am Top

First time I've had the problem, and I use Amazon all the time. I'll try using another source.

17lorannen
Feb 14, 12:15pm Top

We had a spike in Amazon UK add books requests yesterday on a couple fronts. We're looking into where we're at with that now.

18john257hopper
Feb 15, 7:21am Top

This has happened to me this morning, trying to add a book and getting RequestThrottled however I design the search.

19jjwilson61
Edited: Feb 15, 2:20pm Top

>18 john257hopper: What source did you use?

20elkiedee
Feb 15, 2:48pm Top

I would really like to add the UK Kindle edition of a book I've just started, and another UK Kindle book I was just looking at and have realised I already own.

21lorax
Edited: Feb 15, 2:51pm Top

john257hopper (#18)

However you design the search? *Really*?

I doubt that very much - doing a bunch of searches all on Amazon, or different Amazons, doesn't count.

22john257hopper
Feb 15, 4:20pm Top

>19 jjwilson61: Amazon UK

>21 lorax: I meant whichever search terms I used to describe the book in question.

23lorannen
Feb 15, 4:33pm Top

No updates today, I'm afraid—our developer who handles Add Books sources is out of the office today. Sorry, folks. I know it's frustrating.

24Littlemissbashful
Edited: Feb 15, 5:26pm Top

#15

I usually default to Amazon.UK look up because I am most often adding ebooks (bought on Amazon even if not via a link from here) and its a lot quicker to source the title by copying and pasting a single ASIN rather than a ISBN as its more readily available for ebooks and takes you straight to the right edition of the book. Sadly because I am searching for UK ASIN they are not necessarily recognised on other source databases?

It's one reason why other library sources are encouraged. And why we have more than 700 other sources besides Amazon

Yes, I remember seeing (and using) many other sources for look up in the past although I didn't know there were that many and indeed have only now just spotted the tiny additional Add from 4,967 sources towards the bottom of the add items page!!! ...When I was trying the other day I was wondering where all the other alternative options had gone as I could only see the various Amazon sources or Overcat! (I am SO observent...)

I must admit I tried using Overcat when it first appeared but it often failed to pull up any result so I stopped bothering. Having tried again over the last couple of days its still not pulling up any usable results, British Library also fails to pull up ebooks, just have to wait for a break in the throttling...

25elkiedee
Edited: Feb 15, 8:29pm Top

>23 lorannen: Thanks lorannen - I'm glad that LT staff get to have real lives too.

I have used the British Library to add the UK hardback edition of Everything Under

26r.orrison
Feb 16, 2:54am Top

If no sources are working for a book, you can always use the "Add manually" link on the Add books page (near the bottom on the left, under Other Options) and just fill in the details yourself.

27Nicole_VanK
Feb 16, 3:11am Top

Apparently it's affecting German Amazon too : https://www.librarything.com/topic/303866

28LolaWalser
Feb 16, 5:11pm Top

French as well

29BerndP
Feb 17, 5:46pm Top

Yes, Amazon.de is still affected too. That's really strange. I added hundreds of books and DVDs with Amazon on LT over the last two years, never had any problems - well, never this kind of problems anyway.

30simon_carr
Feb 18, 3:58pm Top

Still struggling with Uk Amazon searches. As I am trying to add kindle ebooks many of the other sources are not much use sadly.

31jasbro
Edited: Feb 18, 4:28pm Top

>23 lorannen: I've added eight books today that show up on my Home page, but not on my "Your books" page. Is this a related point or something altogether new?

32Maddz
Feb 20, 3:02am Top

Still no luck with Amazon.co.uk - which is irritating as I can’t sideload my purchases onto my Icarus until I’ve logged them. I know I can add them manually but as I’ve a fairly large backlog to add and very limited time to do so before we go away, I’d rather not have to cut into sleep time.

33lorax
Feb 20, 9:55am Top

Maddz (#32):

I'm going to assume from your mention of sideloading that all your purchases are Kindle books, but does the edition have to be correct to be able to do that? Could you add the paper editions, which could be done from non-Amazon sources, instead? You could even edit the ISBN - annoying, but less so than manually adding everything. If your process relies on the ASIN you'd be out of luck, of course.

34vpfluke
Feb 20, 11:20am Top

I find ILCSO or OhioLINK to be a more satisfactory site for full info on a book that I want to add. But these do not have the most recent books. Amazon will sometimes sell books before their "publication date", but these two sources may not get a book entered in until 3-4 months beyond publication.

35timspalding
Feb 20, 12:33pm Top

We are working on this issue.

The problem is, as noted, request throttling by Amazon. We are working to fix it.

36Maddz
Edited: Feb 20, 1:08pm Top

>33 lorax: Yes, these are Kindle books which I find using the ASIN. Most of my ebook purchases are Kindle books got on sale; Kobo doesn’t discount as much or as often, and I loathe managing my purchases through ADE.

Although I can automatically extract the ISBN, the process extracts the first ISBN found - which may well be the paper ISBN, often a hardcover edition.

To check the ISBN is the correct one, I would have to open the ebook in Calibre viewer, poke around for the copyright info and manually add it to the Calibre record.

To get the Kindle edition means using Amazon as the source, if I have to find it on Amazon.com, I’ll pick up the wrong ASIN which can’t be altered on LT.

37timspalding
Feb 20, 2:51pm Top

>36 Maddz:

Because the UK and US ASINs are different?

38Maddz
Feb 20, 3:25pm Top

>37 timspalding: Where there's different publishers or geo-restrictions, yes.

39Littlemissbashful
Edited: Feb 20, 8:52pm Top

UK users: I am currently finding the books using the British Library source and searching by the title and author. This does also pull up ebook editions and imports the correct ISBN when pulling in the information. The format of the edition data is a bit sparse but can be manually amended if its an issue. Not as simple or quick as an ASIN look up but works perfectly well.

40Robertgreaves
Edited: Feb 21, 3:06am Top

I have found that if I enter the ISBN into the LT app it will add the book to my catalogue as usual even if I'm being throttled on the site. I can then add tags etc via the site. It's a bit cumbersome but it works.

41Maddz
Feb 21, 3:56am Top

>39 Littlemissbashful: I tried the BL with my Daily Deal purchase of yesterday - John le Carre’s The Looking Glass War - and it only returned paper books, no ebooks at all. Even if I add that way, there’s still the issue of not being able to add the ASIN.

So I’ll wait, and hope the Kindle backlog doesn’t get too big. At least my other acquisitions can be logged - the Latinx StoryBundle, and some Early Reviewers, and a couple of rare print purchases - the exhibition catalogue for Ashanibarpal and Glen Cook’s Port of Shadows.

42M_Clark
Feb 21, 9:23am Top

I am having the exact same problem since circa one week. I have tried all possible sources and search approaches without success.

43gilroy
Feb 21, 10:15am Top

>42 M_Clark: So you're getting request throttled from the British Library? From a manual entry?

44MarthaJeanne
Edited: Feb 21, 11:46am Top

>42 M_Clark: You don't seem to ever have used any source that is not Amazon. Have you tried Overcat? That could not be throttled as it is an LT database.

BTW, when commenting on a specific edition in your review, it would be helpful to mention which edition you are describing.

45lorax
Feb 21, 11:50am Top

If someone, after a lengthy thread in which many people including Tim have commented that the problem is limited to Amazon, still insists on complaining that they see the problem on "all possible sources", I really don't think they're going to see any response - they clearly haven't bothered to read the rest of the thread, after all.

46timspalding
Feb 21, 12:01pm Top

I have found that if I enter the ISBN into the LT app it will add the book to my catalogue as usual even if I'm being throttled on the site. I can then add tags etc via the site. It's a bit cumbersome but it works.

The app searches Amazon.com. I'd suggest you switch to Amazon.com for now.

that they see the problem on "all possible sources"

If you're searching for ASINs, not ISBNs, nothing but the US Amazons will work.

47timspalding
Feb 21, 12:39pm Top

Okay, we're working the issue. It is somewhat complex, and may require some time.

For now, I've redirecting requests to Amazon from non-US/Canada Amazons. The message looks like this:

"Note: Some non-US/Canada Amazon requests are currently going through Amazon.com."

48Maddz
Feb 21, 3:37pm Top

Searching directly on Amazon.com using the ASIN netted 5 out of 15 titles. The other 10 were all UK published - mostly Gateway SF from the recent sale.

49timspalding
Feb 21, 5:29pm Top

Try now?

I've made a change that uses recent, cached records, before trying to search remotely. For an irritating technical reason, it's still going to say the results are from Amazon, US, but the records will say Amazon UK.

Anyway, work-in-process.

50timspalding
Feb 21, 5:30pm Top

Would love to get a list of ASINs here. I need fodder.

51Littlemissbashful
Feb 21, 6:48pm Top

#50 - Were you after UK or US ASINs or does it matter?

#41 - Sorry Maddz, apparently hit and miss then as to whether an ebook will come up on British Library, but worth a punt if you can be bothered....

52Littlemissbashful
Feb 21, 6:57pm Top

ASIN Samples (UK)

B07F15ZMWV
B00X61MXN2
B01BVD40GE
B01MRGU98U
B07MF8M9CW
B01MSWQ21D
B07GVNWY2H
B01M2WJAD3
B002RI9S06
B07F815713
B07MWCSNJY
B01N6KDPUE
B0768XSLCW
B07MQR1DHP
B01MA51TN7
B07DXNR63B
B011IYIDSM
B07C96XW1D
B07CKXV7R6
B07LCPWDLB

B0184GSB9I (dvd not book)

53timspalding
Feb 21, 7:15pm Top

Hey, can someone who's British go to a work page, and click the right-side link for Amazon.uk, if you have one? If not, you can add one.

The clicks haven't been registering with Amazon. Very irritating.

54Littlemissbashful
Edited: Feb 21, 8:18pm Top

#53 - Do you mean the Amazon.uk Quick Links? Just click them or, what .... I just clicked on links on the last 5 books I've entered but can do more if needed?

55Maddz
Feb 21, 11:18pm Top

I added Colin Dexter’s Last Seen Wearing https://www.librarything.com/work/243448/book/165219982 before all the trouble, no Amazon.co.uk quick link (now added). Clicking on the (direct) gets me to ‘not found’ on Amazon. When I select Amazon.co.uk and get to the pop-up and select the specific edition, I also get ‘not found’. A long press on that edition seems to be searching on the ISBN10 not the ASIN or the ISBN13.

Checking another work, https://www.librarything.com/work/230717/book/140224440, which was added from Amazon.co.uk years ago, which already had the quicklink, only the searches for the paper editions work; the link for the Kindle edition (the last in the list) fails. Searching on Amazon directly for the Kindle edition using the ASIN B00HPYVRL0 or the ISBN13 9781472114921 work but the search using the ISBN10 1472114922 (which is what the pop-up displays) fails. However, a direct search for ISBN10 0756783895 works (that’s the 4th edition in the list).

So, it seems the Kindle Store doesn’t like ISBN10s for some reason but Amazon.co.uk books is OK with them.

56lorannen
Feb 22, 12:47pm Top

>54 Littlemissbashful: Yep, that's what we were looking for. Thank you!

57M_Clark
Feb 23, 5:49am Top

I was searching on Amazon.com and Amazon Germany. Based upon another suggestion, I started searching using Overcat and found that it worked correctly.

58M_Clark
Feb 23, 5:51am Top

Thank you for your suggestion. Searching with Overcat worked.

As requested, I will include information on which edition in future bug reports.

59vangogan
Feb 24, 11:20pm Top

I too get the RequestThrottled error when trying to enter from Amazon.co.uk

60timspalding
Feb 25, 12:20pm Top

Okay, pushed some changes.

UK: Good
Canada: Good
France: Good
Germany: Good
Spain: Good
Italy: Good

China: Broken
Japan: Broken
India: Broken
Brazil: Broken

We're working on the others.

61timspalding
Feb 25, 12:59pm Top

We are waiting on a new approval from Amazon Japan. The others are held up--they require local addresses and/or bank accounts. This seems a very tricky morass.

62DMBGC
Apr 29, 3:31pm Top

I also am having trouble adding books. I have a Boys and Girls Club library of over 3,000 books but haven't been able to add any in the last 3 weeks. What seems to be the problem?

63gilroy
Apr 29, 4:01pm Top

>62 DMBGC: could you give more details? What source are you using? What books are not being found?

Group: Bug Collectors

902 members

92,473 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 303767

Category: Uncategorized

Assigned to all

Reported by Littlemissbashful

Status: Reopened

Feb 13, 12:52pm

95 days since last change

By BerndP

Status log

Reported. Littlemissbashful (Feb 13, 5:05am)

Closed by member. Littlemissbashful (Feb 13, 5:26am)

Reopened. BerndP (Feb 13, 12:52pm)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 134,760,377 books! | Top bar: Always visible