HomeGroupsTalkZeitgeist
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

Your books(French in Green) = Edit(blank)?

Bug Collectors

Join LibraryThing to post.

1bnielsen
Nov 13, 2016, 2:03pm Top

When I look at this book in my catalogue:

http://www.librarything.com/catalog/bnielsen&collection=-1&deepsearch=13...

and use a style (B) which includes Original Language, I can see that LT shows it as French in a green colour, meaning that it is autogenerated. When I look at the same book in Edit mode, the Original Language is shown as (blank).
The TSV export contains French as I hoped it would.

But I don't think it should show up as (Blank) in the Edit mode.

Did something change recently? Or maybe I've just never noticed? I don't think I have other books like this.
Normally (Blank) in Edit mode gives me a Blank in TSV export, I think.

2jjmcgaffey
Nov 14, 2016, 6:43pm Top

Heh. Wrote a paragraph about what green text means and how to make it black...then noticed the username.

The bug/oddity here is that this data, which is not in your catalog, is exporting. I don't think it should be.

I have a lot of green Original Language data, because I don't care about it much so don't bother to fix it; I think it's always been this way. Most green data shows when you go into edit mode, but it may not be possible in ones where the edit is a combo box. Hmm, no, a green Book in media shows as Book, so it's not that simple... don't know.

3bnielsen
Edited: Nov 15, 2016, 6:11am Top

>2 jjmcgaffey: "Heh. Wrote a paragraph about what green text means and how to make it black...then noticed the username."

Heh :-)

But I tend to disagree that green text shouldn't export. I think the bug is that Edit mode shows (Blank) rather than the green text.

But I also agree with your "so it's not that simple... don't know." :-)

I check the export file for a lot of oddities (i.e. you can have invisible UTF-8 characters, that screw up search), so I knew that all my books had Original_Language set. So I was quite surprised to see the (Blank) entry, when I edited the book.

4lorannen
Nov 16, 2016, 12:09pm Top

I'm tempted to mark this one as "Needs discussion," but assigning to Tim first so he can weigh in.

5jjmcgaffey
Nov 16, 2016, 8:27pm Top

I agree that if it's showing data, even green data (and it's possible - as it is with Media), it should show the same data in Edit mode.

Whether it should export is a separate question - I don't think so, but then anything that's green in my books is something I care nothing about and don't care whether or not it shows up in Export. So if it's valuable to some, maybe it should export.

6bnielsen
Nov 17, 2016, 5:27am Top

I'd miss Summary a lot if all green text disappeared from export. But anyway, that's not the point here :-)

7bnielsen
Feb 15, 2017, 3:55pm Top

I just noticed the same thing with Weight.

Jared Diamonds: Collapse:
http://www.librarything.com/catalog/bnielsen&deepsearch=81171841

shows up in my export with Weight = 1.5 pounds and Dimensions = 8.4 x 5.7 x 1.9 cm

(which seems like an awful small book :-)

When I look at it in Catalogue View (Your Books) in a style that shows these two columns, the data appears in green.
When I press Edit I get nothing displayed in neither Length or Thickness (as I'd expect) but also nothing displayed in Weight.

To repeat myself:
I think the bug is that Edit mode shows (Blank) rather than the green text.

(I'll go fix Collapse, so the example will go away. It's 24 x 16.2 x 5 cm, so there's probably another bug in the data, since it looks like 8.4 x 5.7 x 1.9 inches. And the real weight is 1.005 kg)

And another example:
The First Ten Books by Confusius.

0.04 kg 6.77 x 4.33 x 0.31 cm in TSV export and in Catalogue View, but Dimensions are Blank when in Edit Book. (And the data is also wrong. It should be 0.056 kg and 18 x 11.1 x 0.6 cm)

To repeat myself:
I think the bug is that Edit mode shows (Blank) rather than the green text.

8lorannen
Mar 1, 2017, 12:13pm Top

Did some digging on this one, and found something interesting. If I'm signed in as you, and double-click on the Original language field in Your Books, it doesn't show me "French" it shows me a drop-down menu that reads "(blank)". Obviously, the language is set, because it's showing up there.

So I think the bug may be that Your Books is somehow not accounting for green (that is, generated from datasource) text properly.

>5 jjmcgaffey: I understand your point, but it would be really hard to filter out specifically green text on exports. If it's data that's attached to your copy of the book (and not CK)—which this is—it should export with your records.

9lorannen
Edited: Mar 1, 2017, 12:26pm Top

So, to reproduce:

- Add Min ven Maigret by Georges Simenon to your library, using Bibliotek.dk as your datasource. Make sure you choose a record that does not have the Original language indicated when you expand details about the work. For some reason, those that do have it indicated have the language show up in blue text (I'm guessing because it's coming directly from the datasource and not calculated?).
- Set Your Books display style such that Original language is a column that shows on Your Books (Go to Settings > Display styles and look under "Bibliographic" section on the right-hand side to find Original language field).
- View Min ven Maigret in Your Books, showing the Original language column.
- Note that the Original language displays as French, in green text.

From here, you can see the bug in two places:

Your Books:
- Double-click on the Original language field to edit.
- The drop-down menu, instead of showing the current language, French, will come up with "(blank)".
- If I click to save without making any changes, the Original language will save as blank.

Book Edit page:
- Click the pencil icon to the far right of the record to go to the edit book page.
- The Original language drop-down menu on the book edit page also registers as "(blank)".
- If I make no changes, but save the record, even with the original language drop-down menu showing "(blank)", the original language remains set to French.

10bnielsen
Mar 5, 2017, 10:22am Top

Another green weirdness (that I'll make go away in a moment, alas):
http://www.librarything.com/catalog/bnielsen&deepsearch=le+petit+nicolas
showed one the books (Le petit Nicolas a des ennuis) with nothing in the page count. When I went to the edit page, it showed 135 in green text. And now the same search shows the green text. And in a moment it will be corrected into black text. I just thought I'd record the weirdness. (Which could easily be due to database delay).

11timspalding
Edited: Mar 22, 2017, 4:39pm Top

>9 lorannen:

I see no bug in #9.

The book is getting its original language from the work level, so it has no original language on the book level. This is shown. Nothing changes when I save. What's the problem?

12lorannen
Mar 22, 2017, 5:12pm Top

So, Tim and I have finally both arrived at the "not a bug" conclusion, but that doesn't mean it's not misleading/poorly implemented. In this case, it's green text that is coming from the work level Common Knowledge—there is technically no Original language data at the book level.

But, as I said, this is misleading and not intuitive—to understand what's going on, you have to know what green text denotes, and understand about work vs. book-level data, as well as CK (and this field isn't marked as such in Your Books, like other CK fields are).

So, definitely needs some work, even if technically not a bug.

13timspalding
Mar 22, 2017, 10:55pm Top

Okay, I've change it in the catalog--if you double-click, it will show the menu set to the language, even if the language is green and coming from the work level.

It's true this turns on understanding the green text but that's why, if there's any green text, you get this at the bottom of the page: "* Green text is "calculated" text. Calculated text is provided when your own data are absent, and is either based on other columns in your catalog (eg., the "summary" field) or from books in other members' libraries (eg., Dewey, LCC and subjects)."

I have NOT changed the book-edit page. Here and elsewhere, the book page does not show work-level (i.e., green) details.

14lorax
Mar 23, 2017, 9:26pm Top

I am certain that bnielsen knows very well what green text is. Original Language is a special case in that there is both a book-level and a work-level field that are different, rather than one being calculated from the aggregate of the other, and that the work-level is CK. I cannot think of any other field where book-level data is populated from CK data in absence of actual book-level data, rather than from aggregated work-level data. Nor do any other CK fields export. So dismissing this misunderstanding of a very technical and experienced LT user as "stupid users don't RTFM and understand green text", is a bit over the top.

15timspalding
Mar 24, 2017, 9:02pm Top

I'm unclear, do you think I said that?

16bnielsen
Mar 25, 2017, 9:03am Top

Also mentioned here: http://www.librarything.com/topic/253190

And >15 timspalding: No, I don't think you said that. But my original example is weird whether or not you understand green text. Any text showing up in one view (catalogue view) should also show up any other view (edit view), because you (or at least I) often switch between the two views to look at different aspects of a book. When you break this a user will notice and think that some of the information on the book suddently disappeared.

I like the explanation in >14 lorax: but Page Count has similar symptoms as noticed in >10 bnielsen: so I doubt that the explanation covers all the weirdnesses.

So I don't think the bug is about green text, but rather about using different criteria for showing the same information in two slightly different places.

Anyway, this is a minor nuisance, but I like to report bugs when I see them. It's easier to ignore them that way :-)

17lorax
Mar 27, 2017, 9:47am Top

>15 timspalding:

Not in so many words, obviously. But I do think you were dismissive of the differences between this situation and any other green-text field by suggesting that the only possible issue here was a failure to understand green text.

18bnielsen
Mar 27, 2017, 6:52pm Top

>13 timspalding: It is not true that you get the "* Green text is "calculated" text. Calculated text is provided when your own data are absent, and is either based on other columns in your catalog (eg., the "summary" field) or from books in other members' libraries (eg., Dewey, LCC and subjects)." every time there's any green text.

I just searched my catalogue for the word "Herriot" (displayed in style D, but I don't think that matters). It displays 7 books and "It shouldn't happen to a vet" has a green text for the Page Count. But no explanation about greenwashed text.

If I try to edit the Page Count the pop-up box also shows green text for the page count and no explanation.

I'd normally edit the page count just to make the green paint drop off, but I'll let it be for a day or two in case you want to take a look at it.

19newcrossbooks
Nov 26, 8:58pm Top


Sorry to resurrect this old topic but I'm having problems trying to edit green text in the 'Original language' field and it sort of fits in with this bug report.

I prefer to keep 'Original language' blank, unless it differs from 'Language' (ie the book is a translation), as I should then be able to keep track of how many translated works I have. Most sources seem to add data in this way, except Amazon. I'm careful to remove the second language, if necessary, from any books that I have to add via Amazon.

The problem I'm seeing is that a large number of books entered into the LT database seem to already have a second language added in their Work details, regardless of whether they are translations or not. This means that many copies of my books display in my catalogue with an 'Original language' displayed in green text - and I can't change it. I want this field to be blank for most books - but if I change the 'Original language' to blank then it's immediately overwritten by the data held in the Work details when I refresh the page.

I would really like to be able to use the Stats/Memes page to check how many translations I have, and to be able to click on, say, 'Original language' English to get a list of translations from English - but I can't do it. The majority of 'Original language' English books that are displayed, for instance, have English written in green text and are not translations at all.

The bug I see is that I am prevented from entering my own data in the 'Original Language' field because editing to change to a blank field is then seen as having absent data.... (And yet most library catalogues seem to hold their data in the way that I want to)

20jjwilson61
Nov 27, 12:02pm Top

>19 newcrossbooks: The problem I'm seeing is that a large number of books entered into the LT database seem to already have a second language added in their Work details, regardless of whether they are translations or not.

The work level is a rolling up of all the books in that work so it doesn't make sense to say that the work is or is not a translation. The work will contain both original language and translated books.

Why don't you just add a tag for your translated books?

21MarthaJeanne
Nov 27, 12:48pm Top

I want to be able to see original language for my works, and since I read both English and German, it's not obvious what the original language is unless I enter it, so I do, for every book.

22norabelle414
Nov 27, 2:10pm Top

>19 newcrossbooks: There are two Original Language fields, one is book-level and one is work-level. IMO, original language is work-level information and shouldn't be a book-level field at all. But that's beside the point.

I'm not sure what you mean by a large number of books entered into the LT database seem to already have a second language added in their Work details. The only work-level language data is the original language CK field. There is no second work-level language field. Are you seeing two different entries in the original language CK field?

Like >20 jjwilson61:, I would recommend creating a tag or collection as the best way to keep track of translated works.

23newcrossbooks
Nov 27, 10:11pm Top

Many thanks for the responses.

>20 jjwilson61: True, translated copies of a book should normally appear in the same work page as the original book, but I don't think it follows that it doesn't make sense for me to to say that a particular work is not a translation. I think you'll find that most works are only ever published in one language and have never been translated.

When I enter book data from any library source I've found that the 'Original language' always remains blank, unless the work is a translation. The only source I've used where an 'Original language' is always entered is Amazon (usually English/English, French/French etc). Of my books less than 20% currently have an 'Original language' entered, but I've now got no idea how many of these are translations and how many simply hold LT "calculated data" that has mostly been bought in from Amazon.

Of course some books may well be translated into several different languages, but this, to me anyway, doesn't necessarily mean that the 'Original language' is fixed. I have several books that state that they have been translated from an English translation of a foreign work, rather than directly from the foreign work itself. You may not approve but for these I list the 'Original language' as English - and LT allows me to do this. I can change the 'Original language' to whatever I want - providing it's not changed to blank.

And as to using tags - I really want to use tags to note things regarding the content of the book, not to highlight the fact that it's a translation. And I have translations from over 30 different languages into a large number of other languages, so tagging to cope with this is not trivial. The Stats/Memes page conveniently provides a list of all the 'Original languages' in my library, and gives the number of books catalogued in each of these 'Original languages'. Now I find that, because some unwanted 'Original language' data, calculated from "books in other members' libraries", is being forced upon me, this data is meaningless.

>21 MarthaJeanne: Of course I would expect you to add the language that the book is published in, this is entered into the 'Language' box. But why should you then add it to the 'Original language' box as well, unless its a translation? If there is nothing in the 'Original language' box you should be able to assume that the language it's published in is the original language. I'm happy to see German/English or English/German for Language/Original Language, but don't think German/German or English/English is correct, it's not the way libraries normally store their data.

>22 norabelle414: 'Original language' clearly can't be restricted to work-level information - I have to manually enter about 20% of my books because they don't appear on WorldCat and have to enter an 'Original language' for some translated works at book level.

And I'm not sure what you mean when you say that the only work-level language data is in the original language CK field - I don't think this is true. Take, for instance, the last book I entered, The Shadow King by Maaza Mengiste. The book was written in English, and has not yet been translated into any other language. The book information is here:
https://www.librarything.com/work/23294686/book/175891305

I took my data from the British Library Website, as I have a UK edition. On the edit page the 'Original language' is blank (British Library data). On my Your books page, however, the 'Original language' box has 'English' in green text (language=English, Original language=English) and it's added to the 'Original language' = English books on my Stats/Memes page. This 'Original language' change is presumably because the work details list 'Original language'=English (blue text):
https://www.librarything.com/work/23294686/workdetails/175891305

But the 'Original language' in the CK is blank:
https://www.librarything.com/work/23294686/commonknowledge/175891305

Perhaps LT should simply stop using calculated data to populate the "Original language" field as it's not a field that normally holds any data in library catalogues? Then if people want to add data "Amazon style" into this field it won't effect those of us who don't.

24newcrossbooks
Nov 27, 10:29pm Top

>19 newcrossbooks: - You should have reopened this bug report when you added this post.

25MarthaJeanne
Edited: Nov 28, 1:15am Top

No, you can't just assume that a book is not a translation just because the original language is not filled in. Whether or not English language libraries are really consistent in making sure that this information is correctly entered (really? every library for every book?), you cannot assume that the same is the case for libraries in other languages, or even for other English language libraries around the world.

I have seen many cases where the original language is not obvious until you read the small print very carefully. Publishers vary greatly on how clearly they mark this. Major publishers are one thing, but small presses do not always follow best practices. And older books can be a real problem.

I really don't think that adding extra correct data can be considered 'wrong' no matter what certain libraries do to save typing. After all, most libraries enter book titles in sentence case, but LT members tend to prefer more upper case than that.

26bnielsen
Nov 28, 3:45am Top

Thanks for the discussion. It made me remember why I fill out Original Language if it is empty. The problem is that you want it to be empty but if it is empty then LT fills in some computed stuff that you often consider to be wrong.

I think I'm with >20 jjwilson61: in suggesting tags as the solution. Or using the export file and some scripts to pry the information from some other field like Comments.

I put stuff like
Oversat fra engelsk "The Blue Train" af Poul Ib Liebe
in the Comments field and this allows me to keep track of translations and translators.
But of course this means that I have to enter this information for each and every translation, so it is a bit of work. I have a script that reminds me if I forget it, so I don't lag behind.

BTW I'm curious. Could you give an example of a work where the green text is wrong? (I don't doubt that they exist. I just couldn't come up with an example).

27newcrossbooks
Nov 28, 8:47am Top

>25 MarthaJeanne: Libraries are pretty strict in the way they catalogue things. Of course many different library systems are in use throughout the world, but I find that 'Original language' is usually blank and have yet to find one that enters an 'Original language' that is the same as 'Primary language'. Have you found any?

As to titles in sentence case, this is an input style that does vary from country to country. UK libraries input in sentence case but capitalisation rules may be different in foreign languages. In particular, German capitalises all nouns, even the captions used in series numbering, while French does not always capitalise all parts of proper nouns (or so th Bodleian Library, Oxford says). I change the input to make the title exactly as written on the title page (unless everything is in capitals....)

>26 bnielsen: Really the problem is that you want it to be empty but if it is empty then LT occasionally fills in some computed stuff that you often consider to be wrong.

Sadly much of the 'Original language' data appears to be taken from Amazon, rather than filled in by members, so I guess there will be many examples where the green text is wrong. The trouble is that I've corrected any ones I've seen in my catalogue so I don't notice these and the only ones I see green text are where the 'Original language' is the same as the 'Primary language'. I do have cases where others entering books will find incorrect green text if they look, however. Looking at the 'Original language' on work pages :

Here's a bible translation that's recorded as Amharic but would be English in my system, and certainly not Amharic : https://www.librarything.com/work/11468227/book/131671965

Here's another bible translation that should be Ethiopic, but is English : https://www.librarything.com/work/566074/workdetails/150678598 (521 copies on LT). If I pull in an original 1821 copy from Yale University, the 'original language' is listed as Ethiopic (Ge'ez). If I change this to blank then English appears in green text in Your books....

Here's one that is Portuguese, but only because I edited the English/English data that came in from Amazon when I entered the book into my library : https://www.librarything.com/work/20817650/book/149388904 (and I'm the only holder of the book)

Here's one that is Latin, but only because I edited the English/English data that came in from Amazon when I entered the book into my library : https://www.librarything.com/work/20755125/book/148962799 (and I'm the only holder of the book)

Here's an interesting one that records the 'Original language' as 'Not Set' - I have it in my library as Amharic but the Amazon data lists it as English and there's one other copy on LT : https://www.librarything.com/work/5876830/workdetails/141909783

Another interesting book that records the 'Original language' as 'Not Set' is listed on Amazon as Motherland (Amharic Edition) by Ayalew Mergiyaw (2016-06-15) and imports with no language data at all, Primary or Original. I've set Primary to Amharic but left Original as 'Not Set' : https://www.librarything.com/work/19610675/book/141801599

I would guess that many translated works listed by Amazon have incorrect data in the language fields.

A I have said, only around 20% of my books have any "Original language" data listed. It's a field that's left blank after most imports from libraries, and not one that is displayed in any default view, so why does LT insist on adding calculated data to it?

And I also try to add stuff like
Amharic translation of СОЦИАЛИСТИЧЕСКАЯ ОРИЕНТАЦИЯ И ЕЕ КРИТИКИ by Михаил Михайлович Авсенев
to the comments field to show where the translation comes from.

28MarthaJeanne
Nov 28, 12:14pm Top

Luckily, you can't change my data or prevent me from using LT the way it best suits me.

29newcrossbooks
Nov 28, 2:20pm Top

>28 MarthaJeanne: I never said I wanted to change your data, or prevent you from using LT in the way that best suits you. But I'm prevented from using LT in the way that I think best suits me simply because I'm unable to delete what I would call spurious calculated data that overwrites blank 'Original language' entries in my catalogue.

In the vast majority of cases 'Original language' is left blank when adding books from a library source. Why should LT insist on changing this for books simply because Amazon has chosen to store their data differently to libraries?

I don't want to prevent people from adding whatever they want as an 'Original language' - I just don't want this data to effect the way I can use my catalogue.

And what does the LT help page say (if all else fails read the manual...):

Original language
Set this field if the book is a translation from another language.


https://wiki.librarything.com/index.php/HelpThing:Addnew

I rest my case.

30aspirit
Nov 29, 9:48am Top

>19 newcrossbooks: your bug is that the "Blank" selection for language is not treated as a deliberate blank by the autogeneration system, yeah?

I think the argument about cataloguing methods has been obscuring that.

31newcrossbooks
Nov 29, 12:10pm Top

>30 aspirit: 'Language' should always be filled in, even if it's with the 'no linguistic content' option, so I'm not really bothered with calculated data overwriting blanks in a 'Language' entry.

The problem is with the 'Original language' entry as it's supposed to be left blank unless the book is a translation (see >29 newcrossbooks:).

I don't mind if others want to fill the 'Original language' in their catalogues in the way they want, but the bug is that LT is currently using calculated data, taken mainly from Amazon, to complete any 'Original Language' entries that have been left blank

32bnielsen
Nov 29, 4:43pm Top

>31 newcrossbooks: I'm on your side, I think. My pet peevee is "Subjects" which is often broken beyond repair and not editable. I have a few books for which the export file contains something that is not unicode. So yes, we should be able to edit data on our books and not have LT do "what's best for us" :-) (I have some books about programming and some of my reviews contain less than and greater than signs and multiple blanks and stuff like that. And LT messes this up given half a chance.

33norabelle414
Dec 2, 11:39am Top

>29 newcrossbooks: The wiki is user-edited and that page was written in 2008 by a user who hasn't been active since 2011. The definitions there are not canonical.

34newcrossbooks
Dec 2, 2:06pm Top

>33 norabelle414: OK, so you choose to ignore the wiki and complete the 'Original language' entry for every book, regardless of whether it's a translation or not. Fine - it's not a problem.

But why should you expect everyone else to have to do the same?

There is a bug in the current program that is causing data pulled in from reputable library sources to be automatically overwritten, and not necessarily at the time of data entry - just when someone pulls in a copy of the same book from Amazon.

All that needs to be changed to correct this is for the autocomplete to be turned off for the 'Original Language' entry field.

It won't effect the way you complete your data - you either leave Amazon language data as it is when it's pulled in or, if you're entering the book manually, just add the language details you want in the 'Original language' box.

35norabelle414
Dec 2, 3:16pm Top

>34 newcrossbooks: It's not "ignoring the wiki". There is nothing stopping me from changing the wiki to say "fill out this field regardless of whether the book is a translation". The wiki entry (currently) is just one interpretation made by one user eleven years ago. (As evidenced by the fact that someone seems to have tried to review a book on that page?)

36newcrossbooks
Dec 2, 10:29pm Top

>35 norabelle414: Of course there's nothing to stop you, or anyone else, from changing the wiki - but no-one has felt the 'Original language' entry needs changing in the last eleven years (and the page was last updated on 1 July 2019). This is because the recommendation follows standard library practice to leave the 'Original language' field blank unless the work is a translation.

I try, where possible, to upload data in to my catalogue from reputable library sources. If the Library of Congress does not have a copy of the book then I look on WorldCat to try to find a library that does, and then check to see whether that library data can be accessed via LT. Because of the large number of foreign books in my collection I've uploaded data from over 120 different library sources from all over the world. Not one of them has ever filled in the 'Original language' field if the work is not a translation. The only source I've used that routinely fills it in, translation or not, is Amazon (and I've found it often gets the 'Original language' wrong for translations).

Please lets try to get the bug fixed that's causing legitimate blank entries in this field to be overwritten - it won't effect the way that you choose to work.

37lorax
Dec 3, 10:58am Top

You seem to be under the misconception that anybody *knew* about that particular Wiki entry.

Personally, I think the library practice of deliberately omitting data with the understanding that it is to be inferred from the value of another field is silly, and always enter Original Language, but I honestly don't care enough to edit the wiki, though I may do so if you keep insisting that we are all Doing It Wrong based on the wiki entry.

38newcrossbooks
Dec 3, 12:02pm Top

>37 lorax: The Wiki entry merely confirms that LT is trying to store its data in a way that is compatible with the way that libraries store their data. I am certainly not under the misconception that anybody *knew* about the Wiki entry - I only found it myself a few days ago when trying to confirm that LT expects that 'Original language' should normally be left blank.

But if that is the way that LT thinks it best to store data then it shouldn't be attempting to autocomplete blank entries in this field - this is the bug I'm trying to report.

I don't mind if you think that "the library practice of deliberately omitting data with the understanding that it is to be inferred from the value of another field is silly" and prefer to always complete the 'Original Language' field. But why should that effect my entries that follow standard library practice? This is what is happening at the moment and I have no way of preventing it.

Store your data the way you like but please lets fix this bug so that your data entries, and many others who regularly pull in data from Amazon, don't prevent me from working with my data in the way that I would like simply because LT is auto-completing entries unnecessarily/incorrectly.

39lorax
Edited: Dec 3, 12:32pm Top

It's not the way "LT" thinks best to store data. It's the way one random LT member thought it best to store data back in 2008.

I definitely agree that you should be able to enter your data as you see fit, but focusing on the Wiki entry is really, really not helping you here. Just focus on your request (to have a way to distinguish deliberately-blanked data from unpopulated data, in this and all other fields where it's relevant), and stop jumping up and down about the Wiki or the "correctness" of your approach.

40newcrossbooks
Dec 3, 8:17pm Top

>39 lorax: Sorry but it's not me focusing on the Wiki. This started at >19 newcrossbooks: and the Wiki wasn't bought into it until >29 newcrossbooks:. And I only looked at the Wiki because a few people who responded were surprised that I wanted to leave the 'Original language' field blank, and didn't believe that this was standard for libraries. Now everyone seems to be jumping up and down because I've found something in the Wiki that helps prove my point, but that they disagree with...

The fact is that the way LT pulls data from any, any reputable library source means that the 'Original language' data is always, always blank unless the book is a translation. This is clearly why the 'one random member' wrote what they did in the wiki in 2008 and why it's never been changed.

I can't think of any other main entry field that would normally be expected to be blank (except, I suppose, 'Other authors' - I've never looked to see if there are any 'green' entries in my data in this field).

So I'm not looking for a way to distinguish deliberately-blanked data from unpopulated data, I'm just trying to get the autocomplete turned off for 'Original language' so that my blank data fields aren't overwritten unnecessarily and everyone is happy.

LT should not be using 'calculated data' to overwrite blank data entries in the 'Original language' field - it's a bug that needs to be fixed.

41newcrossbooks
Dec 5, 5:30am Top

Following on from >40 newcrossbooks:, I've now checked more of the 'Other authors' field in my catalogue. I can find no 'green' entries.

I've checked further by adding the well known two author book Tiny Pretty Things by Sona Charaipotra and Dhonielle Clayton to my library to check how 'Other authors' entries are currently handled by LT (over 280 members have this book in their catalogue). I pulled in the data from the Library of Congress and, as expected, the 'Author' was recorded as Sona Charaipotra, the 'Other authors' as Dhonielle Clayton and the 'Original language' was left blank.

I edited the book in my collection to remove Dhonielle Clayton's name from 'Other authors' (ie left it blank) and saved it. On checking the entry in 'Your books', LT made no attempt to autocomplete the 'Other authors' entry - though 'Original language' was changed to English (green text).

I added the book again but this time pulling in the data from Amazon - the 'Author' was recorded as Sona Charaipotra but the 'Other authors' entry was left blank and 'Original language' was listed as English.

So LT doesn't attempt to autocomplete a blank 'Other authors' entry (which is good as this field is usually blank when data is pulled in from library sources), but does currently autocomplete a blank 'Original language' entry (which is bad as this field is also usually blank when data is pulled in from library sources).

LT should not be using 'calculated data' to overwrite blank data entries in the 'Original language' field - it's a bug that needs to be fixed.

42MarthaJeanne
Edited: Dec 5, 7:57am Top

This is hardly comparing like with like. It is hard to imagine a book which has a different original language from another copy of the same work. But many of the other authors vary a lot. Different translators, different illustrators, different cover artists. Just because other people's editions have one of these listed doesn't mean that the information is true for some other copy.

There is a CK field for original language just because most entries do not have this field filled in.

Perhaps closer is the way LT treats LC Classification. I don't use it, consistently replace it with -, but my book details page shows the work information NOT what is entered in my copy.

Or use of sentence case, like most libraries, where LT tends (like your catalogue) to prefer more upper case.

The bug in the OP was that edit book page and export were treating this differently. That has been fixed.

If you don't like the way LT does this, that is not a bug. Perhaps an RSI.

43newcrossbooks
Dec 5, 9:42pm Top

>42 MarthaJeanne: I said in my >40 newcrossbooks: post "I can't think of any other main entry field that would normally be expected to be blank (except, I suppose, 'Other authors' - I've never looked to see if there are any 'green' entries in my data in this field)" - so I looked, was able to report in >41 newcrossbooks: that "LT doesn't attempt to autocomplete a blank 'Other authors' entry (which is good as this field is usually blank when data is pulled in from library sources)". This does mean LT doesn't try to use calculated data to overwrite every blank data entry it finds so I would expect a fix for overwriting 'Original language' to be fairly easy.

As to translations, I have several books in foreign languages that are clearly marked as being a translation of an English translation of a book that was originally written in a different language. Libraries can catalogue a chain of translations but LT only allows one, so for these books I choose English as the original language. For instance, one book I have is an English translation of a French translation of a Portuguese book, and I have another, later copy, in English that is a direct translation from the Portuguese. I catalogue the 'Original language' of these differently, but make a note in the 'Comments' about the translation chain. Other people may choose to enter the books differently. I don't really use Common Knowledge myself, except for adding a book to a series, but would guess 'Original language' here would be marked as Portuguese (though what original language you enter for things like Bibles I don't know).

But the problem I have isn't with translated books, LT keeps any data that I type in to the 'Original language' field for my translated books, regardless of whether other people might think it correct or not. The problem is with the vast majority of entries that I add that are not translations and where the 'Original language' is left blank because the data is added via library sources. You say "There is a CK field for original language just because most entries do not have this field filled in" but don't appear to recognise why most entries do not have this field filled in.

The problem then is that if anyone else then enters the same book on LT, but chooses to add data in the 'Original language' field, or pulls in the data from Amazon and saves it without removing the language data that Amazon puts in the 'Original language' field, then my blank data field is overwritten with that data and I can do nothing about it. As was said in >26 bnielsen: "Thanks for the discussion. It made me remember why I fill out Original Language if it is empty. The problem is that you want it to be empty but if it is empty then LT fills in some computed stuff that you often consider to be wrong."

LT is currently overwriting 'Original language' data pulled in from library sources - this is a clearly a bug.

As to the LC Classification, it is the Library of Congress's classification code that it gives to every book it catalogues. It is currently one of the most widely used library classification systems in the world and the classification code for each book is set by the LoC following strict guidelines - you can't expect to be able to change it. See here for more details https://www.loc.gov/catdir/cpso/lcc.html
If you're not interested in the LC Classification, or the LCCN for that matter, then don't display them - there's no point in trying to modify or erase them - they are what they are.

Group: Bug Collectors

921 members

94,064 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 239875

Category: Your books (catalog)

Assigned to timspalding

Reported by bnielsen

Status: Reopened

Nov 27, 10:29pm

10 days since last change

By newcrossbooks

Status log

Reported. bnielsen (Nov 13, 2016, 2:03pm)

Fixed. timspalding (Mar 22, 2017, 10:55pm)

Reopened. newcrossbooks (Nov 27, 10:29pm)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 140,140,545 books! | Top bar: Always visible