HomeGroupsTalkZeitgeist
Big news! LibraryThing is now free to all! Read the blog post and discuss the change on Talk.
dismiss
This site uses cookies to deliver our services, improve performance, for analytics, and (if not signed in) for advertising. By using LibraryThing you acknowledge that you have read and understand our Terms of Service and Privacy Policy. Your use of the site and services is subject to these policies and terms.
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

LibraryThing App update (version 1.1.0)

New features

Join LibraryThing to post.

1lorannen
Jan 23, 2019, 1:27pm Top

Both Android and iOS users of the LibraryThing App now have version 1.1.0 available to them. You'll need to update the app on your mobile device in order to see it in action. In our first major update since the app's release, we've focused on adding more cataloging sources, better filtering and browsing of your own library, and making sure the app works well for iPhone X users.

Download the latest version of the app on iTunes or Google Play.

Let us know what you think!

More data sources

We've added all of LibraryThing's almost 5,000 cataloging sources to the app. Previously, only OverCat and Amazon.com were available. Now, you can choose your favorite libraries and copy-catalog directly from their records on the go. Note: Your Add Books data source preferences from LibraryThing.com do not carry over into the app. You'll need to update them on your mobile device, too.

To change your Add Books data sources on the app, from the home screen, tap "Account," then "Edit Sources." That will show you a list of your current sources. Tap "Add sources..." to add more. From there, you'll be able to show sources based on popularity, country, or select your favorite Amazon source. Check the box next to the source you'd like to add:



Browsing your books

You can now view lists of your books based on Collections, Authors, and Tags. From Home, tap "Your Catalog" to see these categories and filter your books. You can also search within a given Collection, author, or tag. Below, you can see the library categories, along with the tag view for my own library.



As always, once you've filtered down to a specific Collection, author, or tag, you can see your books in list view, or cover view—below you can see all my Terry Pratchett books in cover view. Tap the icon in the upper-right corner to switch between list and cover view.



iPhone X

We've fixed the display problems reported by iPhone X users. The iPhone X "notched" layout was tricky, but all should be working smoothly in the latest version.

2anglemark
Edited: Jan 23, 2019, 1:48pm Top

Never mind chirp chirp

3thorold
Jan 23, 2019, 2:44pm Top

Thanks! :-)

4conceptDawg
Jan 23, 2019, 3:01pm Top

To be clear, the iOS update has been available for a month or so and the Android version for a little over a week. So if you have auto-updating turn on—the default setting for most people—you already have this version.

5thorold
Jan 23, 2019, 3:07pm Top

...but unless we’d been watching carefully we didn’t know about the new features.

6anglemark
Jan 23, 2019, 3:08pm Top

>4 conceptDawg: Yes, I realised that some minutes after posting.

7lorax
Jan 23, 2019, 4:11pm Top

Reinstalled after a long hiatus, figuring I'll give it another chance to see if the overeager "a slip of the finger and your book is gone forever" behavior has changed, but I just get a spinny icon when trying to view my catalog.

8lorannen
Edited: Jan 23, 2019, 4:16pm Top

>7 lorax: I've been testing a lot the last week or so (on Android) and haven't run into this behavior. You've already signed in, right? At what point in the process does this happen? After tapping "Your Catalog" or after you've selected a category within the catalog page? And, remind me: are you iOS or Android?

9lorax
Jan 23, 2019, 4:27pm Top

lorannen (#8):

I'm on Android. Just re-installed the app, as I said. Signed in with no problem, and if I go to "Home" it shows my username. If I click on "Your Catalog", it just spins; I can't tell you what happens if I select a category, since I can't get to that point.

My library's not large, only about 3K books, so I don't think it's a size issue.

10bnielsen
Jan 23, 2019, 5:54pm Top

>9 lorax: Just for the record: I'm also on Android and with a 7K library and not seeing this, so I also don't think it is a size issue.

11conceptDawg
Jan 23, 2019, 6:12pm Top

>9 lorax: I'll take a look tonight and see if there's a data issue going on.

12Robertgreaves
Jan 23, 2019, 6:42pm Top

When adding sources, is it possible to rank them? I have stop at the first source with results turned on, but can I choose the order?

13conceptDawg
Jan 23, 2019, 11:27pm Top

>12 Robertgreaves: The order in which they are listed on your Account screen is the order in which they will be tried.
You can sort your selections within the edit screen (although I think that Android can sort them in place in the listing screen too, I don't have one on me at the moment to be 100% sure as we went back and forth on that one).

14saltmanz
Jan 24, 2019, 12:30am Top

Was just trying to search my library from the app tonight (on Android), and ran into a huge problem. In the new filtering options in the Your Library screen, it appears that All Books and Tags only return results from the "Your library" collection. (The Collections and Authors filters do not appear to have this problem.) So for example, if I go to the Tags page and click the tag "ebook" (which it says has 3184 books) it says "The collection is empty". (I keep all of my ebooks in their own collection.) Likewise, if I go to All Books and search for "ebook", none of my 3184 ebooks show up.

15riaanw
Jan 24, 2019, 12:43am Top

I love the app. It's quick and useful. The only thing still missing for me is the inclusion of the DDC field on book view: my large collection of books at home is arranged by Dewey number, so to find the number for a specific book, I still have to click through to the LT website from the app.

16Robertgreaves
Jan 24, 2019, 12:46am Top

>13 conceptDawg:

I added Amazon UK to my Android phone but it is not showing up as a source on my Android tablet despite having the latest version on both.

Without deleting sources and then re-adding them, there doesn't seem to be any way of changing the order of sources on the edit sources screen.

17gilroy
Jan 24, 2019, 5:23am Top

>17 gilroy: The edit of order is done on the main account screen, not on the edit sources screen.

Just open comment: Trouble on my android version - When a source goes to a second line, it loses the slider icon to allow it to be reordered. Example: Southern Maryland Regional Library Association. No slider icon to move it, but all others with a single line like Overcat can be slid around it.

18lorax
Jan 24, 2019, 8:38am Top

Update:

The slowness I was experiencing earlier may have been related to having uninstalled the app. Currently everything is working okay.

19saltmanz
Edited: Jan 24, 2019, 11:26am Top

Search doesn't really seem to be working for any search that would return more than a few dozen results. (Again, Android.)

If I try any of the following searches, the app just spins and spins and never returns anything. (The number in parentheses is the number of items returned by the desktop version.)

ebook (3193)
female author (641)
star wars (277)
james roberts (89)
red sonja (85)

The following searches, however, do work in the app:

john barber (70)
glen cook (56)
malazan (45)
lovecraft (32)

20conceptDawg
Jan 24, 2019, 11:30am Top

Thanks for the notes. We very much appreciate them. We'll take a look at each issue and get some fixes out as soon as possible.

21saltmanz
Edited: Jan 24, 2019, 11:31am Top

Also, one feature request: I have over 1500 tags, so scrolling through the list to find a specific one takes forever. I see that when you scroll, there's a little progress indicator that pops up on the righthand side. Would it be too much to ask to make that a slider, to allow for instant scrolling to anywhere in the list?

22lorannen
Jan 24, 2019, 11:32am Top

>14 saltmanz: That's concerning. I'm not able to reproduce this behavior in my own account. Have you tried pulling down on the screen to refresh? Is the Collection in question one that is still marked as "active" in your account?

>17 gilroy: That's a useful note. Confirmed that I'm seeing the same issue.

>18 lorax: Glad to hear it!

23conceptDawg
Jan 24, 2019, 11:34am Top

>14 saltmanz: Thanks for that report. That filtering is certainly not intentional and we'll get that fixed.

>15 riaanw: I can look at adding Dewey in the next version. It shouldn't be a problem at all.

>16 Robertgreaves: We don't share settings between devices. So you'll need to set up your source list separately on each one.

>17 gilroy: Ick. That's no good. We'll figure out what's going on there and fix.

>19 saltmanz: Very detailed report. Thanks. We'll figure out what's causing that and fix it.

24conceptDawg
Jan 24, 2019, 11:36am Top

>21 saltmanz: Hm. There is supposed to be an alphabetic slider on the right there. We'll try and figure out why it's not working in some cases.

25saltmanz
Edited: Jan 24, 2019, 11:58am Top

I'm on Android 7.0 on an LG AT&T phone, by the way, if that helps for any of this.

>22 lorannen: Yeah, I've tried killing and restarting the app, swiping down to refresh, rebooting my phone, etc. (And yes, all of my collections are active.) Just going into the All Books section sorted by Date Added is what tipped me off as to what was going on, since it clearly shows only my physical books, which is all I use my "Your Library" collection for, and I've almost exclusively switched to buying ebooks for the past year or two. I can pull "Your Library" up on the desktop version and sort by Entry Date, and the list is an exact match for the app's "All Books".

26igorken
Jan 24, 2019, 2:34pm Top

A few minor issues in the new version (Android); nothing important but if you're looking at this anyway:

1) The number of "collections" listed in the initial "Your Catalog" screen is higher than the actual number of collections that show up when I click it. (9 vs 7)





2) The slider that appears on the right in the list of tags/authors partially obscures the numbers, which looks a little weird. It would look better if either the numbers were to the left of that slider, or alternately completely covered by it.



3) In the list of authors, it tells me I have one book with [no author], but when I then click that, I'm told that collection is empty.



27VicRML
Jan 24, 2019, 8:22pm Top

I don't find any of these new fiddly bits on my phone, but the app info says I have version1.1. There's no update pending. Should I uninstall and reinstall the LT app?

28conceptDawg
Jan 25, 2019, 12:35am Top

If you have 1.1 I don't see any way that you couldn't have these items. But certainly try to reinstall, it can't hurt.

29kristilabrie
Jan 25, 2019, 10:36am Top

>27 VicRML: You might also try re-starting your phone, before un-installing/re-installing, just in case!

30rsterling
Jan 26, 2019, 7:14am Top

I've removed Amazon as one of my sources and added two others in addition to Overcat, but when I try to add books, most almost all search results are still coming from Amazon, and the Amazon ones are always listed first. Is it somehow defaulting to Amazon even if Amazon is not one of the sources in a user's list?

31gilroy
Jan 26, 2019, 8:21am Top

>26 igorken: on the no author glitch, mine says I have 54, but the collection is empty.

32gilroy
Feb 3, 2019, 9:58am Top

Okay, first attempt at adding a book using the app done last night. Not a single one of my selected sources is Amazon when it comes to books. YET! When I added the book Corrupted , it sourced the details from Amazon.com.

This is not acceptable. PLEASE FIX.

33VicRML
Feb 9, 2019, 5:35am Top

>29 kristilabrie: Thanks, Kristi. Works well now - plus I'm learning more about how to drive my phone. ;-)

34conceptDawg
Feb 15, 2019, 1:58am Top

>26 igorken: The bug with the number of collections being incorrect has been fixed.

35conceptDawg
Feb 15, 2019, 1:59am Top

>26 igorken: The no author thing is a strange side-effect of how we're dealing with non-author attributed books and the search layer that we're using to find those books. We'll solve this soon but not today, as it's an infrastructure issue.

36conceptDawg
Edited: Feb 15, 2019, 2:08am Top

We have a fix for the adding of all books from Amazon when using the Android version. We'll get that fix rolled out by the end of this weekend (a few days).

We'll also have a fix for the never-ending search within the catalog.

37gilroy
Feb 15, 2019, 9:32am Top

What should we expect the build number to be or will this become version 1.1.1?

38igorken
Feb 15, 2019, 12:55pm Top

39conceptDawg
Feb 16, 2019, 1:41pm Top

>37 gilroy: I'll let you know when we release it. I'll post here.

40timetunnel
Edited: Feb 21, 2019, 1:43pm Top

There is another bug in the list of authors: it doesn't show the author name which I used for my book, but instead shows the "main" author name (or "most common" author name? Not sure what the correct English term is here).

Example:

I have several books by "Arkady Strugatsky" (https://www.librarything.com/author/strugatskyarkady), which I entered using his different German spellings "Arkadi Strugatzki" or "Arkadij Strugatzki" and who wrote most of the books together with his brother "Boris":



In the list of authors, however, he is displayed only as "Arkady Strugatsky", though none of my books uses this name. The number of his books are nevertheless correct in the list, at least for the count as "first author":



When I tap on his name to see the books, it says "The collection is empty":



I'd expect to see his books at this point, and the author's name in the way how I entered it for the book.

Closely related to this example I also have a feature request:

As already said above, Arkady Strugatsky wrote most of his books together with his brother Boris Strugatsky. It'd be great if not only the "first author" would appear in the list of authors, but all authors. Without this feature, the list can display a somehow "wrong" number of books per author. In my example, I have most of their books entered with "Arkadi Strugatzki" as first author, but some with "Boris Strugatzki" as first author. This appears in my list as 9 books by "Arkadi Strugatzki" and 2 by "Boris Strugatzki", though they actually are both authors of these books and the number 11 should be shown for both authors (see images above).

41Lindsay_W
Feb 24, 2019, 9:25pm Top

In the old android app when I added a book it went to currently reading and my library. Can I delete them from Currently reading and still have them appear in "your books" ? I like that the new app asks you where you would like to put them.

I have unselected currently reading so It won't do it anymore but want to make sure if I click on the red x in currently reading that it won't delete them altogether.

The barcode scan option is awesome.
Thank you

42divinenanny
Feb 25, 2019, 4:49am Top

>41 Lindsay_W:
If you are using the website to change the collections your book appears in, don't click the red X! That will delete your book from all your collections, including "Your Books".

Assuming you're on the "Your books" page, click the box with the arrow. You should see a dropdown with the collections that specific book is in (selected) and not in (not selected). Just de-select "Currently Reading" to remove any book from that collection.

If you want to quickly do it for all books, go to the "Currently Reading" collection, click on the lightning bolt in the bar just below the navigation bar of LT. This is Power Edit. Select all books you want to remove from "Currently Reading", go to the Collections tab in the Power Edit menu, select "Currently Reading" and "Remove from Collection" and click "Change Selected Books" to the right.

43conceptDawg
Feb 26, 2019, 2:20pm Top

v1.1.1 of the Android app is available.
Most of the bugs mentioned above should be fixed but there are a couple that are still hanging out there because they will take more time and we didn't want to hold up an update.

44vladmihaisima
Feb 27, 2019, 2:58am Top

Is there anywhere a change-log/list of fixes? I guess using the correct sources for lookup is not yet fixed, but would be nice to know for sure....

45lorannen
Feb 27, 2019, 12:45pm Top

>44 vladmihaisima: Not yet! I'm working on adding that info to the Help page soon. In the meantime, there is a log that shows on the iTunes or Google Play pages (both linked from the Help page) that tells you what was fixed/added/etc. in the latest version.

46gilroy
Feb 27, 2019, 12:57pm Top

>45 lorannen: Google play just says Bug Fixes. Doesn't specify which ones.

Though one of the big ideas behind this patch I thought was the sources issue...

47conceptDawg
Feb 27, 2019, 5:55pm Top

The two things that didn't make it into the 1.1.1 version are the fix for multi-line sources and the paginated scrollbar for long lists. Those are coming in the next fix.

48gilroy
Feb 28, 2019, 5:08am Top

>47 conceptDawg: So it will pick only Amazon still?
*looks at building pile of books to add*

49conceptDawg
Feb 28, 2019, 12:53pm Top

>48 gilroy: That should be fixed also.
If you find that it is NOT then certainly let me know.

You can also remove the sources from your list and add them back again. That will update the settings for each of the sources.
Alternative, remove the app and install it again (I'm loathe to mention this as a solution for every problem, but in this case—because it's saved-settings related—it would probably work).

50vladmihaisima
Feb 28, 2019, 3:10pm Top

>49 conceptDawg: conceptDawg: If you find that it is NOT then certainly let me know.
For me it is not working.

(Android) Removed all sources (except one) and re-added all - no book found
(Android) Uninstalled LibraryThing application, installed LibraryThing application, removed all sources except Overcat and added all country's sources (for Romania) - no book found.
(web) Looked up same book by ISBN on website - book found
(Android) Disable Overcat - no book found

Note: I have checked the ISBN (978-606-758-719-7) is correct at each scan, and I did not add the book at none of the step above (to be able to continue testing).

Please tell me if I can test anything else.

Is the Android application open source? The more eyes on a problem easier is to spot it...

51lorannen
Feb 28, 2019, 5:04pm Top

>50 vladmihaisima: What book are we talking about, and what data source(s) did you use on the main site? Your data source settings do not carry over from the app to the website.

52vladmihaisima
Mar 1, 2019, 4:26pm Top

>51 lorannen: lorannen: What book are we talking about, and what data source(s) did you use on the main site? Your data source settings do not carry over from the app to the website.

The sources I mention for Android are all sources for Romania.

The source I find the book at is "Biblioteca Naţională a României" (which is in the list on Android)

The book is the one with the listed ISBN (978-606-758-719-7), which I did not add yet to LibraryThing, so not sure what do you mean by "What book are we talking about".

For now I did not add the book - in case it is easier for someone to test.

>51 lorannen: lorannen: Your data source settings do not carry over from the app to the website.

Will summarize the step above:
If I do a search on the website (even without adding the book), and then a search with the Android app including overcat, the book appears.
If I do a search first on the Android app, without including overcat, but using the source for which I found it on the website, the book does not appear in the Android app.

What I want is to use the Romania sources for the (many) books I have already of which many are not to be available in overcat. I could add everything by introducing manually the ISBN (as the books are in the sources) but it is cumbersome and defeats one of the purposes of having an app.

53maspotts
Mar 2, 2019, 12:55am Top

Any chance of providing a "siri shortcut" so I can look up books in my library from within a "shortcuts" workflow on ios? Something like "Get LibraryThing Books" taking optional collection, tags, authors and/or search arguments. Would be able to either open the app and execute the search, leaving you in the app looking at the results, OR (crucially) return the list of books (as a json structure) ready for further processing in the workflow.

54lorannen
Mar 4, 2019, 7:42pm Top

>52 vladmihaisima: I really do need specific examples in order to test this out. I'm sorry, I'm having trouble following.

- A book you've searched for that displays this behavior
- What data source(s) you have selected when you're running your search
- What text string you're using in your search

Searching by ISBN, title, etc. should still get you the book you're looking for, ISBN is just more precise to the edition. I'm not sure under what circumstances a book wouldn't turn up in title search but would on ISBN, using the same data source.

55lorax
Edited: Mar 5, 2019, 1:25pm Top

lorannen (#54):


I'm not sure under what circumstances a book wouldn't turn up in title search but would on ISBN, using the same data source.


Oh, I can think of at least two that don't involve user error:

1. There are non-ASCII characters in the title, and character set issues mean what gets searched for isn't what's in the system.

2. There's a subtitle including a colon, and the source is one (like the LOC) where searches including colons fail.

Edited to add: I opened an RSI touching on the second one six years ago, so it's not like it should be a surprise that it happens: https://www.librarything.com/topic/144254

56vladmihaisima
Mar 6, 2019, 3:27am Top

>54 lorannen: lorannen A book you've searched for that displays this behavior

ISBN (978-606-758-719-7)
Source "Biblioteca Naţională a României" (one of the sources of country Romania).

For the app by search I mean scan the barcode.
For the webapp by search I mean put the ISBN in the search box.

For detailed steps on how this happens (because, if you search first on website and then scan the barcode it finds it, problem if I try to just use barcode scan. One possibility being it is somehow using the overcat cache) please check post 52.

57ChristieStrantz
Mar 8, 2019, 2:56pm Top

Just downloaded the app on ios version 1.1.0.

Everything is great except for the author tag under Your Catalog.

All of my authors show up with the number of books I have by them showing in parentheses but when I tap on the author it tells me the collection is empty.

I really want to be able to see the books I have for each author but I don't want to have to create a bunch of collections to do it. Especially when this feature is apparently already there but not working.

Please, please, please fix this.

58lorannen
Mar 8, 2019, 5:04pm Top

>57 ChristieStrantz: I'm not seeing this in my own catalog, I'm afraid. Can you post specific examples of the authors you've looked at? It may be that some combining needs to be done.

59AvengingExile
Mar 11, 2019, 4:43pm Top

Will the old "Readar" app ever be integrated into this? I really like using Readar when I travel to find bookstores, but I couldn't install it on my newer iPhone (iPhone 8).

60lorannen
Mar 13, 2019, 12:20pm Top

>59 AvengingExile: That's the hope, eventually.

61AdrianPizarro
Mar 16, 2019, 5:54pm Top

Is there some way I can help translate this app to Spanish? I really like this website and I'd like it to reach a greater audience in Latin America/Spain, but people can't use what they can't understand. I've been helping with voluntary translations here last year, so I think I can do well.

62conceptDawg
Mar 20, 2019, 10:32am Top

>59 AvengingExile: that is the hope.

63lorannen
Mar 20, 2019, 3:42pm Top

>61 AdrianPizarro: The app is only currently available in English, I'm afraid. We'd like to add other languages (since, as you're probably aware) the main site is translatable, but that's going to be some time before it's released, unfortunately.

64adam.currey
Mar 25, 2019, 7:22pm Top

Are there any plans to develop the editing pages of the app to be more mobile friendly? The app looks and works very nicely, until you click the edit button and drop into what looks like a mobile-unfriendly web page.

65lorannen
Mar 25, 2019, 7:46pm Top

>64 adam.currey: Yes, that's on the list, but will be a while coming. I don't know if it's likely to be in the next release or not, yet.

66adam.currey
Apr 8, 2019, 11:41pm Top

Thank you.

67arienrhod1
Mar 26, 7:02am Top

Bug in the android app:

If you click the tag that has a colon in it (for example "content: vampires") then it doesn't find the books and says "the collection is empty".

Tags with colons work fine on the website.

Group: New features

45,319 messages

This group does not accept members.

About

This topic is not marked as primarily about any work, author or other topic.

About | Contact | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 143,929,601 books! | Top bar: Always visible