HomeGroupsTalkZeitgeist
  • LibraryThing
  • Book discussions
  • Your LibraryThing
  • Join to start using.

Android App bugs

Bug Collectors

Join LibraryThing to post.

1lorannen
Jun 15, 3:24pm Top

For now, we're going to keep one on-going thread for all Android app bugs. If you're having trouble with the Android app, post about it here. The more details you can give us, the better (i.e. device type, Android version).

iOS app bugs should not be posted here. Create a new Bug Collectors thread if you're having trouble with the LT iOS app.

Main Android app Talk thread: https://www.librarything.com/topic/259440.

2civitas
Jun 16, 12:04pm Top

Bug: Book's Comment Field Doesn't Render Markup

For example: bold is displayed as: <b>bold</b>

Android App: Version 1.0 (build 19)
Android Version: Android M (Marshmallow 6.0.1)
phone: Samsung Galaxy J3 Sky

See the screen shot:

3conceptDawg
Jun 16, 12:43pm Top

Thanks. We're already looking at this but it's good to get a solid report with a good set of examples.

4lorannen
Edited: Jun 16, 12:44pm Top

Woops, >3 conceptDawg: beat me to the punch!

5FortFairfieldLibrary
Jun 16, 6:03pm Top

Downloaded to Samsung SM-T377V Verizon 6.0.1 tablet. The app will not scan a bar code.

6FergusS
Jun 19, 4:58pm Top

Sorry - posted on other thread before realising this one was for bugs.

I'm having an issue with camera upside down when scanning cover, and movements to align reversed (move left to get image to move right etc). Nexus 5X Android 7.1.2.

7lorannen
Jun 19, 5:08pm Top

>6 FergusS: Thanks for reporting. Looks like there might be something with the Nexus 5X—we'll try to get this fixed!

8lorannen
Jun 19, 5:09pm Top

>5 FortFairfieldLibrary: Can you give us some more details about where the problem is in scanning? Have you tried multiple barcodes, tried changing the lighting? Are you scanning on a flat surface?

9civitas
Edited: Jun 21, 10:13am Top

>2 civitas: Bug: Book's Comment Field Doesn't Render Markup

In build 20, it now seems the markup has been stripped from the text prior to display. Unfortunately, gone also are all the line control characters. The result is a blob of unformatted text.

edit (6/21): A closer look shows some of the markup is rendered, but not all. Italic is there, but bold and line control characters are gone. Also rendered correctly are links (not shown in this example)

Android App: Version 1.0 (build 20)
Android Version: Android M (Marshmallow 6.0.1)
phone: Samsung Galaxy J3 Sky

See the screen shots:


Left: Chrome App (OK)       Right: LT App (build 20)

   

10conceptDawg
Jun 19, 6:53pm Top

THere's a new beta version available that has multiple bug fixes/improvements.
I've created a new Talk thread to keep up with releases and announcements for the app.

LTApp Android Updates/Announcements

Not sure if we'll use the same thread for multiple announcements or one for each update...kinda depends on the traffic.

11civitas
Jun 20, 8:49am Top

>9 civitas: Bug: Book's Comment Field Doesn't Render Markup
>10 conceptDawg: new beta version available ...

From the new announcement thread:
HTML within comments, private comments, and reviews is now displayed correctly.

The comments field's HTML still isn't being displayed correctly - see the screen shot above. The same is true of the private comments field as well.

Android App: Version 1.0.1 (build 21) beta
Android Version: Android M (Marshmallow 6.0.1)
phone: Samsung Galaxy J3 Sky

12FortFairfieldLibrary
Jun 20, 10:38am Top

Yes, and have also downloaded a separate barcode app, to double check my tablet/camera, and it works fine.
I tried multiple books, in daylight laying on a flat table right here in the library.
I can see the barcode, in the box, but many times it's blurry, especially ones with book covers.
No matter how close or distant it never clears up. With the barcode app, I just have to adjust the distance.
I've taken some screenshots, but not sure how to upload them here.

13JerryMmm
Jun 20, 11:20am Top

>12 FortFairfieldLibrary: you can use the junk drawer on your home page, either in unused or some other section of the home page you've put it on.

14civitas
Jun 20, 12:11pm Top

>12 FortFairfieldLibrary: No matter how close or distant it never clears up

What version and build number of the App are you using? This sounds like a problem that an earlier version was having.

If you go to the Home page => Account page and look at the LibraryThing logo at the bottom, the Version and build number will be just under it.

15FortFairfieldLibrary
Edited: Jun 20, 2:17pm Top

Version 1.0.4 build 21

Signed up for the beta version, to get the update. I do get a bit better results, but still far from the ease shown on the video.
I found if I am right over the barcode when I hit the scanner button for each book, it focuses better and I get a 1 or 2 books out of 5 reading.
If the scanner is already open, and then go over the bar code, it's blurry and never focuses. I have to go back to the add books page, hit the scanner again while over the next book.
I can't just go from book to book

Here how the bar code looks in Librarything app - http://pics.cdn.librarything.com/picsizes/38/0c/380c2b0f7be080a636e4f326f51434b4...
and
http://pics.cdn.librarything.com/picsizes/fd/67/fd6748b5817bb77636d36326f51434b4...

This is how a scan looks with the generic barcode scanner app - http://pics.cdn.librarything.com/picsizes/f2/9d/f29daba65100105636e61326f51434b4...
http://pics.cdn.librarything.com/picsizes/9d/0f/9d0fc044502b327636e69326f51434b4...

16gilroy
Jun 20, 2:18pm Top

If I had a focus issue when trying to scan a barcode, I always drew the phone back until the barcode looked clear, then lowered it slowly until the phone focused and found it.

I also frequently stumbled across barcodes that weren't ISBN codes.

17conceptDawg
Jun 20, 2:43pm Top

>15 FortFairfieldLibrary: What device type/Android version are you using?

18lwbooklover
Jun 20, 8:00pm Top

I'm having the same problems as FortFairfieldLibrary. I downloaded the app from the Play store today and have not been able to get it to scan once. I've tried with flash off and on, in sunlight, under lamp, etc. I've tried books, CDs, and DVDs. No luck.

The app is Version 1.0 Build 19.

I'm using an AT&T Samsung Galaxy S7. Android Version 7.0

The other barcode scanners on my phone work. This is the only one not working.

19JerryMmm
Jun 21, 8:06am Top

Have you tried taking a picture of the barcode with proper focus, then switching to the scanner?

20AmishTechie
Edited: Jun 21, 10:04am Top

I went to Google Play to get the app. It gave me version 1.0 r 19 Using Samsung ON5 Android 6.0.1
I was having problems with the focus. I did twenty books just fine, then no matter what i did it would not focus.

I join the Beta users and updated to V 1.0.1 r 21

Okay... The first time I used this version it worked fine. Then if I stopped or did anything else, it stopped focusing. I went to my other scanning software, used it once. It focused. Then went back to the app and it worked fine as long as I was careful to not loose focus. If I did, then I had to start over.

Keep you posted.

21civitas
Edited: Jun 21, 11:29am Top

>9 civitas: civitas: Bug: Book's Comment Field Doesn't Render Markup
>11 civitas: Bug (continued)

Some (most?) of the markup is being rendered correctly. In particular, links are now correct (not shown in the example. I have a lot of them in my comments)
Still problematic though, is that <b>bold</b> doesn't show up and all the line control characters are gone.

I've added a note to entry 9.

22conceptDawg
Jun 21, 10:45am Top

Thanks for the feedback. We'll work on getting focus and html fixed.

23mdow
Edited: Jun 21, 11:04am Top

I’m having trouble with using the scanner to add DVDs. I’ve added books very easily (yay!) but when I scan the barcodes on my movie collection nothing comes up. I can, however, add DVDs by manually typing the ISBN printed above the barcode. It's not a lighting issue (books successfully scanned in the same lighting conditions).

Moto G Play 4
Android 6.0.1

24jjwilson61
Edited: Jun 21, 11:27am Top

>23 mdow: Whatever the barcode on a DVD is it isn't an ISBN, which stands for International Standard Book Number. It's probably a UPC. Maybe UPCs work when searching on Amazon but I think the app probably detects if the barcode is a valid ISBN and if it isn't it rejects it.

25lorannen
Jun 21, 11:54am Top

>24 jjwilson61: Not quite. UPCs on DVDs and CDs should scan. I had a bunch of my own movies cataloged this way at one point.

>23 mdow: Can you give us some examples of specific DVDs you're running into this problem with? I noticed my older ones don't always scan properly.

26FortFairfieldLibrary
Jun 21, 1:37pm Top

Samsung SM-T377V Verizon 6.0.1 tablet as stated in my first post. The tablet is less than 3 months old.

27mdow
Edited: Jun 21, 2:10pm Top

>25 lorannen: I have tried DVDs of Braveheart, Stranger Than Fiction, Moonstruck, and a Harry Potter box set purchased last November

Edited to add: I have build 19, and the Google Play Store says there aren't any updates. I tried on another handful of movies, ranging from Chicken Run to Breakfast at Tiffany's to Casino Royale, and the app did nothing when presented with the barcodes. They were in focus, but no result came up.

28Zathera
Jun 21, 8:08pm Top

I have a Samsung Note 10.1 Tablet
Model number: GT-N8013
Android Ver1sion 4.1.2
Kernel version 3.0.31-813049
dpi@SWDB4807 #1
SMP PREEMPT Fri Sep 18 21:08:55 KST 2015
Build Number JZO54K N8013UEUC0I1

The app loaded just fine, and works well. However, I cannot scan with it.
I was able to scan with the app from my Android phone. The same books did not work on the tablet.
Any suggestion would be welcome.

29conceptDawg
Jun 22, 2:50am Top

>28 Zathera: When you say you can't scan with it, do you mean that the scanner never starts? or that it just doesn't pick up the barcode correctly? Or what?

30resuttor76
Edited: Jun 22, 4:36pm Top

I have an ellipsis 8hd and am having a scanning problem. I place the barcode in the scan window and nothing happens. I can add books to my library manually. Editing is working fine also. Scanning seems to be the only issue at the moment. Just talked to the owner of the Book Haven in Prescott Valley, AZ and she showed me how to use the scan app correctly. I was not using the barcode on the inside front cover of the older paperback books. Hope that helps.

31conceptDawg
Jun 23, 3:17am Top

>30 resuttor76: We are working on some fixes to the scanning function. It seems that it is having problems focusing on some devices.

32ricgerace
Jun 23, 9:41am Top

Misidentified book.

I used the app to scan 'Go Set A Watchman' 9780062409850 this morning, testing to see if the app would recognize a duplicate. The app scanned the code and identified the book as 'To Kill A Mockingbird' which is in my library as 9780062420701. I deleted the entry, which was marked as a duplicate, and repeated the process three times, with the same result each time.

Snappy, fast little app, and I look forward to finishing entering my library into LT, but this behavior gives me pause. Is it the app or is it me?

Ric Gerace
Cape Cod

33lorannen
Jun 23, 11:45am Top

>32 ricgerace: Can you tell us what type of device and Android version you're using? Also, check what data sources you've selected in Account under "Add to Catalog: Sources"—it sounds like somebody's got some bad data out there, if I had to guess the cause of this issue.

35civitas
Edited: Jun 23, 2:07pm Top

>32 ricgerace: ... scan 'Go Set A Watchman' 9780062409850 ... [got] ... 'To Kill A Mockingbird'
>33 lorannen: it sounds like somebody's got some bad data
>34 davidgn: I think I might know who, as well...

The proximate cause does seems to be bad Amazon data. My app shows Amazon as the source for this ISBN. If you go to Amazon and do a search, it returns two books in this order: Go Set A Watchman / To Kill A Mockingbird.

But there may to be an App related issue too. When scanning, the App evidently takes the last item from the returned list. I've noticed this as a source of error when testing the scanner.

An example: scanning the ISBN 0-940450208 The Leatherstocking Tales, Volume I ... the App selects an entry from a German library cataloged under the title The pioneers, or, The sources of the Susquehanna a descriptive tale. The ISBN is correct but the title isn't (it's actually a portion of the sub-title). The entry came from Overcat. Note: this Library of America volume has 73 entries in Overcat, the selected entry number is 62. The reason I think that the App may be taking the last entry is that 62 is suspiciously close to the programmer friendly number 64, such as would be a reasonable default size of a container to hold the result of database query. I am of course guessing here.

Another example (I don't recall the book) the App selected the last of six Amazon entries: the first four were correct, but the last two were bad.

What's the solution?
- take the first entry - Amazon may already order by most probable (another guess on my part)
- try to figure out a best entry
- treat the scan as a keyboard entry and just display the list of possibilities (my preference)
- declare it a feature of high-speed entry by scanner.

36ricgerace
Jun 24, 7:08am Top

I'm using an LG Stylo 3, Android version 7.0.

I can't find the "Add to Catalog: Sources" item you mention.

37djchase
Jun 25, 12:48pm Top

My problem is the same. My info is the same except mine is a Verizon phone.

38gilroy
Jun 26, 7:56am Top

>36 ricgerace: >37 djchase:

In the App, tap on the "Account" button. The Add to Catalog:Sources should be about midscreen, listing either Libraries or Amazon.

39lorannen
Jun 26, 11:40am Top

>37 djchase: Which problem? You didn't reply to a specific thread, and this is a catch-all for all Android app bugs (for now). You can reply to a thread by typing the right arrow ">" followed by the number of the post you're replying to, with no space between the two.

40scmason
Jun 26, 2:02pm Top

I have a Blackberry Classic which will run Android apps. However, when I try to download the Librarything app from Google Play, the only option is Install which does not work for me. I need to download then install.
Any suggestions for solving this problem?

41lorannen
Jun 26, 2:05pm Top

>40 scmason: Waiting for confirmation from developers, but I'm pretty sure the app doesn't work on Blackberry, I'm afraid. If I understand correctly, Blackberry has it's own OS, and the app is for Android devices.

43conceptDawg
Jun 26, 2:16pm Top

Some blackberry devices DO run Android (albeit their own flavor of Android, much like every other manufacturer). Unfortunately, we don't have one of these BB devices to test on so I can't say why it's not installing. We aren't doing any filtering of devices on our end and if it shows up on the store as ready to install then it should install without issue. We don't do that part of the supply chain.

Unlike iOS where we pretty much have every single device type to test on there's just no way that we can have every one of the, literally, thousands of devices that the app is available to run on for Android.

44djchase
Jun 26, 7:29pm Top

#18

45conceptDawg
Jun 27, 3:52pm Top

We are working on some fixes for the scanner focusing problems on some devices. We should be ready to beta test those later this evening.

46Stevil2001
Jun 27, 8:36pm Top

HTML in reviews now seem to render correctly, with the exception of line breaks-- my multi-paragraph reviews are just one big blob of text!

47RobKates
Jun 28, 12:33pm Top

Frequently when I add books to my library I set tags at the same time. In the app, which is wonderful, there doesn't seem to be a way to set the tags to populate along with the new book. I can go back and adjust later, but would prefer to set the tags at the same time as scanning the books. Is there something I am missing here? Galaxy 5S with 6.0.1.

48lorannen
Jun 28, 2:00pm Top

>47 RobKates: Nope, that's not a bug. We don't currently have the ability to add/edit Tags in the app, but we're hoping to add that down the line.

49scmason
Jun 28, 3:05pm Top

With regard to my query about using the Librarything app on a Blackberry Classic phone, I found the procedure for setting up my phone at playstoreblackberry.com.

This will only work on newer Blackberry phones using OS 10.1 or higher.

I followed the procedure and the app installed and works beautifully.

Perhaps add this link to the site on the relevant web page for others to use.

50gilroy
Edited: Jul 1, 12:45pm Top

LT App Build 23 Version 1.0.2
Samsung S8 Verizon (Android version 7.0, Kernel 4.4.16)

Trying to take in covers, and it's limiting the image to the center square of the screen, which is cutting off the image when taken. It's forcing me to hold the phone higher, so my image needs more trimming, thus making for a less clear and clean cover image.

When I had an S4, the image was a full screen image, not limited to the central square.

51JDEllevsen
Jul 2, 1:04am Top

I'm unable to scan DVD or Bluray barcodes with the Android app. I can scan book barcodes, although I find the app does this a couple of times before saying it has encountered a problem and has closed.

To avoid problems with reflections on plastic, I remove the DVD's paper insert and scan that on a flat surface.

The scanner is able to focus, but nothing happens. There's no error message; it just doesn't recognise the product or add it to my collection.

I'm in Australia but a lot of my DVDs/Blurays are from overseas, so I don't think this is a region 4 barcode issue.

My Android version is 6.0.1

I've tried updating and reinstalling the app.

52OysteinH-O
Jul 2, 9:10am Top

I've found that the app doesn't seem to work well with recent Norwegian books that aren't already on Librarything. I'm able to find the books via the website, for instance by searching by source "BIBSYS (Norway)" or "Bergen folkebibliotek" or "Kristiansand Folkebibliotek".

This exposed something about how your system works that made giving you a good example a bit clumsy: if I try to scan a book that the app doesn't find, then go find it via the website's "Add books" search, I can THEN find the book in the app, even though I didn't actually add them to my library. So I guess you guys add books from search results to your catalog, even if the user searching doesn't.

Anyways, here's the ISBN and barcode for a couple of books that I cannot find via the app. I assume the same is true here, that the moment someone looks it up via the website, they'll also be available in the app. Please let me know if you need more examples. I've not looked them up on the website, so I assume as long as no one does, the app still won't find them.

978-82-02-50099-3
Hilde Lindset - Til Døden

978-82-93-36837-3
Heinz Schilling Marthin Luther: Rebell i en Brytningstid

Image of their barcodes:
http://imgur.com/a/oNpgO

53jjwilson61
Jul 2, 10:45am Top

>52 OysteinH-O: So I guess you guys add books from search results to your catalog, even if the user searching doesn't.

Not quite. Successful library searches are added to the Overcat "source", but the books aren't added to anyone's catalog on LT.

54OysteinH-O
Jul 2, 10:50am Top

Ah, makes sense. I figured there was a sort of internal Librarything "works" catalog that they got added to, but I guess Overcat sort of works like that.

55MrsMich02
Jul 2, 12:38pm Top

I'm using a Samsung Galaxy S5 with Android 6.0.1 using LT version 1.0.1. Scanner will not scan dvds or cds or any older i.e. 15 yrs book. Works on newer books ok. Little fussy with the focus and needs a rest after say 15. Sound will turn itself on and off randomly. Can add dvd and cd and older by going on desktop site and adding that way

56mdow
Jul 4, 1:48am Top

>55 MrsMich02: and >51 JDEllevsen: I've had the same problem with DVDs.

57PocketSable
Jul 4, 9:31am Top

I decided to try barcode scanner today (seeing as how my CueCat seems to have run off somewhere) and I absolutely can't get it to work. It's in perfect lighting, the focus is perfect, the barcode is center but it simply does not take the barcode. I've tried Paperback and Hardcover, new and old. I'm running on Android Lollipop 5.1 on an LG Rebel LTE Phone. I know it's not a problem with my camera as I actually deposit my paychecks from my phone without issue using the camera. It just does not seem to recognize anything as a barcode.

58macacamulatta
Edited: Jul 5, 1:24pm Top

Just picked up the android app yesterday. I have never used LibraryThing at all, but I am familiar with cuecat scanning, and will try that on my pc next.

I'm working thru the app from a samsung tablet sm-t310 (4.4.2 operating system). So far, only one book has scanned correctly. I have tried numerous times on mass market paperbacks, outer code, or inside flap code...none are recognized.

One issue with a tablet is the default placement of the reader bar, since it automatically forces a shadow made by the tablet itself over the book being scanned (or not scanned in my case). The shadow creates a distinctly unreadable code, but maneuvering a light source to clear it up still renders the scanner useless so far.

I read upthread that the camera being upside down may be an issue, but flipping my tablet to avoid the shadow, I have no idea if my camera would then be considered upside down since I have only had success scanning the 1 book, and was not paying attention to my method of achieving that.

Will keep trying, and reporting.

Edited to add... Trade paperback equals success.
Mass market paperback no go on the scans.
Need more info on best practices for mmpb scanning or adding
Since I'm new to Librarything, I need to read about general limitations of the site.

59MRBruns
Jul 7, 6:10pm Top

Download Build 21 on Samsung tab 4.

Model SM-T23ONU
Android 4.4.2
Kernel 3.10.0-6808427

I can not get the scanner to focus. I tried lighting. Flat surface. Going in and out etc. Download a QR Barcode scanner and it works.

60Dashbored
Jul 8, 3:19am Top

Google Nexus 5X
Android 7.1.2
Kernel version 3.10.73-g932ac95a6be

When I select "Your Catalog" from the Home screen or the bottom, I am unable to select (and browse) a specific Collection. I am forced to search within the last Collection to which I added a new book. The only workaround I've found is to go to Cover Explorer and find a book that is in the Collection I am interested in viewing, select it and then select the link for the Collection to which it belongs. The app then displays that Collection and allows me to view it but not search it.

Otherwise, I'm very pleased with the app and love LibraryThing.

Thanks!
Seth Goodman

61nicole.r.katz
Edited: Jul 8, 8:10am Top

I have an LG Stylo and I can not read any VHS or DVD...it does books just fine

62JDEllevsen
Jul 14, 12:03am Top

Following on from my last post about not being able to scan DVDs to add to my collection, I've run another update.

This time the error message was 'No books found for the given ISBN (9317731131295)'. I tried another, older DVD and it worked. Go figure.

63lorannen
Jul 14, 1:27pm Top

>60 Dashbored: Can you explain a bit more about this? When you say you're unable to view a specific collection, does that mean that you don't see a list of collections to choose from at all, or just that tapping on a collection name does nothing?

>61 nicole.r.katz: and >62 JDEllevsen: Not all DVDs and CDs will be scannable. Especially for those with UPC barcodes (rather than ISBN), our data sources can be a bit hit or miss. Currently, the only source we have for that info is Amazon, and about half of my own DVD collection doesn't turn up any results.

A good way to check and see if it's the app that's the problem (rather than a simple lack of data to pull from, which we can't do much about), is to search Amazon for the barcode, or type the barcode numbers into the Add Books search bar, either on your app, or on the main site. If you don't get any results there, either, then it's no surprise they're not scanning.

64thegreattimsbooklist
Jul 18, 10:35am Top

Android OS - latest update
LT app - latest update
Samsung Galaxy S6

Same problem as mentioned in post #50

Taking cover pictures while holding the phone in portrait orientation cuts off the top and bottom of the book cover. Even looking at the live image while aiming up the shot, everything looks... squished. As mentioned, holding the phone significantly above the books helps, but then it's not a very clear shot.

Taking cover pics while holding the phone in landscape orientation seems to solve the problem, but then they upload that way too and I can't seem to turn the image 90* to fix it.

Group: Bug Collectors

837 members

87,074 messages

Bug Tracking

This topic is part of LibraryThing's in-talk bug tracking.

Join or watch Bug Collectors to get "Bug Tracking" under "The World" in Talk all the time.

Bug (edit)

ID: 259639

Category: Android App

Assigned to all

Reported by lorannen

Status: Needs discussion

Jul 14, 12:03am

9 days since last change

By JDEllevsen

Status log

Reported. lorannen (Jun 15, 3:24pm)

Needs discussion. JDEllevsen (Jul 2, 1:04am)

Needs discussion. JDEllevsen (Jul 14, 12:03am)

About

This topic is not marked as primarily about any work, author or other topic.

Touchstones

No touchstones

You are using the new servers! | About | Privacy/Terms | Help/FAQs | Blog | Store | APIs | TinyCat | Legacy Libraries | Early Reviewers | Common Knowledge | 116,080,640 books! | Top bar: Always visible